- Posts: 26
- Thank you received: 4
[SIPS-ATOS]Soucis de validation de commande.
[HikaShop version] : 2.2.0 business
[Joomla version] : 2.5.11
[PHP version] : 5.4.17
[Browser(s) name and version] : chrome
Bonjour,
Nous avons un soucis avec le plugin SIPS ATOS, qui marchait très bien en phase de tests.
En mode production, la commande se passe très bien jusqu'au paiement final avec la banque
Mail de la banque
noreply at e-transactions.eu
[/url]
Your transaction has been accepted and registred.
Please find further information related to your purchase below.....
Voir ici le rapport du Débogage du plugin ATOS
System
Reading F_DEFAULT (htdocs/inscriptions/media/com_hikashop/pc.x) OK
Reading F_PARAM (inscriptions/media/com_hikashop/pc.**********************) OK
Reading F_CERTIFICATE (inscriptions/media/com_hikashop/b/ct.fr.****************) OK
Version du certificat = 23/05/2013 (ETRANSACTIONS)
Le soucis est au niveau du passage de statut "créé" à "confirmé".
Quand la commande à été créée et payée, elle reste sur "créé"
Voici le rapport du Fichier de log pour les paiements :
Erreur lors de l'appel de l'API\nMessage d'erreur:
API ERROR
Error get DATA response parameter (wrong length)
\nCould not load any order for your notification Erreur lors de l'appel de l'API\nMessage d'erreur:
API ERROR
Error get DATA response parameter (wrong length)
\nCould not load any order for your notification Erreur lors de l'appel de l'API\nMessage d'erreur:
API ERROR
Error get DATA response parameter (wrong length)
\nCould not load any order for your notification Erreur lors de l'appel de l'API\nMessage d'erreur:
API ERROR
Error get DATA response parameter (wrong length)
\nCould not load any order for your notification
Comme je disais plus haut, j'avais réglé ce problème en phase de test www.hikashop.com/forum/5-support-en-fran...ips-atos.html#108870
en production, le bouton "Activer le mode validation" est sur non.
Je suis dans l'impasse, je n'ai plus d'idées
Please Log in or Create an account to join the conversation.
Je pensais que vous aviez résolu votre soucis dans ce topic www.hikashop.com/forum/5-support-en-fran...tut-de-commande.html ce n'est pas le cas?
A la vue de votre message d'erreur on dirait que les données renvoyées par votre banques sont vides.
Est-ce que les commandes annulées changent bien de statut?
Please Log in or Create an account to join the conversation.
Pour infos quand on arrive sur l'interface de la banque et qu'on clique sur le bouton annulé on est redirigé vers : tarbesentango.fr/inscriptions/atos.php ou la page reste blanche. Si on rentre dans la barre d'adresse sans rien changer mais qu'on valide en appuyant sur entrée le message suivant s'affiche :
Erreur lors de l'appel de l'API\nMessage d'erreur:
API ERROR
Error get DATA response parameter (wrong length)
\n
Le même message qu'on retrouve dans le fichier de log des paiement
Et de retour sur la page "Commandes" sur l'interface Hikashop le statut de commande ne change pas et reste sur "créée".
Pour info l'hébergeur est 1&1 sous serveur linux
Merci par avance pour votre aide...
Please Log in or Create an account to join the conversation.
Eliot wrote: Je pensais que vous aviez résolu votre soucis dans ce topic www.hikashop.com/forum/5-support-en-fran...tut-de-commande.html ce n'est pas le cas?
Salut Eliot,
Non ce n'était pas le cas, j'ai été obligé de récupérer les fichiers media/com_hikashop d'une sauvegarde du début juillet, ça à résolu une partie du problème. Actuellement, le site est en phase de production, on en revient à ce topic www.hikashop.com/forum/5-support-en-fran...mande-sips-atos.html que j'avais résolu, nous étions en phase de tests.
J'avoue que j'y perd un peu mon Latin
Please Log in or Create an account to join the conversation.
J'ai voulu me faire rembourser la commande que j'avais passé. Je l'ai passé manuellement à remboursé, ça change bien de statut.
Bonjour Pierre,
Votre commande No. *** est maintenant remboursée.
Par contre, je ne reçoit rien de la banque (aucun mail), les 12€ ont bien été débité.
Est-ce que les commandes annulées changent bien de statut?
J'annule la commande.
Je reçoit le mail du site :
Bonjour Pierre,
Votre commande No. *** est maintenant annulée.
Toujours aucun mail de la banque :
Autoriser les notifications de paiement par SIPS ATOS Crédit agricole est bien coché sur OUI
Please Log in or Create an account to join the conversation.
Le fichier payment > param > parmcom.0130... se présente actuellement ainsi :
# URL de retour automatique de la reponse du paiement
#AUTO_RESPONSE_URL!!
# URL de retour suite a paiement refuse
CANCEL_URL!http://!
# URL de retour suite a paiement accepte
RETURN_URL!http://!
# END OF FILE
Apparemment ce devrait plus être ça :
# URL de retour automatique de la reponse du paiement
AUTO_RESPONSE_URL! www.tonsite.com/client/plugins/atos/call_autoresponse.php !
# URL de retour suite a paiement refuse
CANCEL_URL! www.tonsite.com/regret.php !
# URL de retour suite a paiement accepte
RETURN_URL! www.tonsite.com/merci.php !
Le problème c'est que je n'arrive pas à trouver sur le serveur le fichier call_autoresponse.php à part dans le dossier payment > sample > call_autoreponse.php où d'après ce que j'ai compris c'est un fichier d'exemple donc absolument pas configuré...
A l'aide !!
Please Log in or Create an account to join the conversation.
dans le répertoire /inscriptions/payment/bin
Il y à des fichiers du genre response.exe et request.exe
sur un serveur linux, c'est un peu paradoxal.
Ces fichiers n'ont n'a pas été modifié depuis le 29/05/2013
Ce qui est bizarre, c'est que ca fonctionnait bien en mode test ...
Please Log in or Create an account to join the conversation.
blog.manit4c.com/2009/12/18/installation...iel-premiere-partie/
par contre qu'est-ce qu'on fait du fichier call_auto_response.php et surtout où est-il ?
Please Log in or Create an account to join the conversation.

par contre qu'est-ce qu'on fait du fichier call_auto_response.php et surtout où est-il ?
Il est ici
/inscriptions/payment/sample
Il n'a pas été modifié depuis le 29/05/2013,
je pense que le problème est presque résolu, il faut actualiser ce dossier avec le kit proposé par e-transaction ...
Please Log in or Create an account to join the conversation.
Les fichiers nécessaires à ATOS sont générés automatiquement par Hikashop en fonction des informations que vous donnez. Du que ATOS n'accepte pas de chemin trop long, nous avons du tricher un peu en renomant les fichiers, ainsi le parcom que vous regardez n'est pas celui utilisé (allez jeter un oeil à la doc c'est assez bien expliqué www.hikashop.com/support/documentation/8...yment-atos-form.html ).
Dans tous les cas, les fichier .exe n'ont en effet rien à faire là.
Please Log in or Create an account to join the conversation.
$pathfile="pathfile=chemin_du_fichier_pathfile"; c'est pas vraiment une adresse valide ça...
Et du coup pourquoi tout marchait bien en pré-production ??
Please Log in or Create an account to join the conversation.
Pour ce qui est de la différence avec la pré-production je suppose que la réponse se situe là où le bug est.
Please Log in or Create an account to join the conversation.
J'ai réinstallé le kit atos dans un répertoire "payment" à la raçine du site.
Le dossier qui était présent n'était pas configuré, ou mal (mea culpa).
bin
- request
- response
param
- certif.fr.0*************1.php
- certif.fr.0*************2.php
- parmcom.0*************1
- parmcom.e-transactions
- pathfile
sample
- call_autoresponse.php
- call_request.php
- call_response.php
J'ai configuré les fichiers
pathfile : fichier de configuration où il faudra indiquer les différents chemin des dossiers et fichiers utiles.
Ensuite le parmcom.0*************1
call_request.php
call_autoresponse.php
J'ai pas testé, je pense que c'était ce qu'il manquait.
j'espère qu'il n'y à pas de coquilles dans les paths.
Bonne journée
Pierre
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.