- Posts: 7
- Thank you received: 0
Une erreur s'est produite [résolut]
-- Joomla version -- : 3.9.6.
-- PHP version -- : 7
-- Error-message(debug-mod must be tuned on) -- : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'Array GROUP BY order_payment_method ORDER BY Total DESC LIMIT 1' at line 1
Bonjour, ce message est arrivé lorsque j'ai voulu mettre sur "panneau de contrôle" une visibilité sur la méthode de paiement la plus utilisé pour payer au passage des commandes.
Hikashop fonctionne quand même je ne peux pas aller sur le "panneau de contrôle" simplement.
Merci
Please Log in or Create an account to join the conversation.
Je suppose que vous parlez du dashboard du backend. Et je suppose que vous utilisez l'ancien dashboard du backend.
Du coup, vous pouvez gérer les widgets du dashboard dans le menu Commandes>Rapports.
Là, désactivez le rapport qui fait l'erreur et le dashboard refonctionnera.
Vous pouvez aussi nous fournir une capture des options du rapport pour que nous puissions essayer de reproduire le soucis.
Please Log in or Create an account to join the conversation.
ouiJe suppose que vous parlez du dashboard du backend.
je ne sais pas.Et je suppose que vous utilisez l'ancien dashboard du backend.
Effectivement, en déactivant "Main Statistics" je peux revenir sur le "panneau de contrôle"Du coup, vous pouvez gérer les widgets du dashboard dans le menu Commandes>Rapports.
Là, désactivez le rapport qui fait l'erreur et le dashboard refonctionnera.
En cliquant sur Main Statistics j'ai > pièce jointe "Capture.JPG"
Ce qui fait au final que j'ai un panneau contrôle peu utile et un rapport non modifiable.
Merci
Please Log in or Create an account to join the conversation.
Vous pouvez recréer un rapport configuré de la même m'anière qu'avant sans la ligne pour les stats sur les méthodes de paiement et vous retrouverez vos statistiques sur le dashboard.
Après, je veux bien regarder le soucis, mais votre message d'erreur ne donne qu'un morceau limité de requête MySQL et je ne sais pas comment est configuré votre rapport, donc je navigue un peu à l'aveugle.
La première chose, ce serait de faire cette modification:
www.hikashop.com/support/forum/product-c...eld-list.html#304882
Et ensuite réaffichez la page avec l'erreur. Cela fournira la requête MySQL entière ce qui sera déjà utile pour analyser la situation.
Please Log in or Create an account to join the conversation.
impossible de le faire j'ai ce message lorsque je veux enregistrer mon rapport fraichement paramétré.Vous pouvez recréer un rapport configuré de la même m'anière qu'avant sans la ligne pour les stats sur les méthodes de paiement et vous retrouverez vos statistiques sur le dashboard.
Le message est celui que me donne la gestion hikashop. Je n'ai rien tronqué.mais votre message d'erreur ne donne qu'un morceau limité de requête MySQL et je ne sais pas comment est configuré votre rapport, donc je navigue un peu à l'aveugle.
Cette modification semble être déjà en place dans ma version de hikashop.La première chose, ce serait de faire cette modification:
www.hikashop.com/support/forum/product-c...eld-list.html#304882
Merci pour votre aide.
Please Log in or Create an account to join the conversation.
Cette modification rajoute l'affichage de la requête MySQL en dessous du message d'erreur. Vu que vous n'avez pas la requête, jene peux que conclure que vous n'avez pas la modification. Merci de revérifier.
Sinon, c'est peut être que vous avez quelque chose de spécial avec la connection à la base de données sur votre site. Quel driver MySQL utilisez-vous ? Avez-vous Falang ?
Please Log in or Create an account to join the conversation.
Effectivement j'ai mal lu le topic... voici le message que j'ai après avoir mis en place la requête.Cette modification rajoute l'affichage de la requête MySQL en dessous du message d'erreur. Vu que vous n'avez pas la requête, jene peux que conclure que vous n'avez pas la modification. Merci de revérifier.
MariaDBSinon, c'est peut être que vous avez quelque chose de spécial avec la connection à la base de données sur votre site. Quel driver MySQL utilisez-vous ?
Non.Avez-vous Falang ?
Merci
Please Log in or Create an account to join the conversation.
Merci. J'ai ajouté un patch de notre coté. Cela devrait résoudre le soucis.
Téléchargez le paquet d'installation sur notre site et installez-le sur le votre pour avoir le patch et cela devrait être bon.
Please Log in or Create an account to join the conversation.
Effectivement ça marche. J'ai de nouveau accès aux statistiques entièrement.
Merci
Please Log in or Create an account to join the conversation.