- Posts: 326
- Thank you received: 17
ReCaptcha v2 a disparu du formulaire (pas le message invitant à cocher la case)
-- Joomla version -- : 2.5.28
-- PHP version -- : 5.6
Bonjour,
je viens de découvrir qu'à la création d'un compte, le plugin ReCaptcha v2 n'affiche plus la case qu'il faut cocher, alors que le plugin est toujours activé et qu'il fonctionnait récemment...
Sur la console google recaptcha j'ai un message qui explique peut-être cela, mais je ne vois pas comment résoudre le problème :
Y a-t-il eu du changement quelque part ?Nous avons détecté que votre site ne vérifiait pas les solutions fournies aux tests reCAPTCHA. Vous devez les vérifier afin d'utiliser correctement la fonctionnalité reCAPTCHA sur votre site.
Merci
Cordialement
Pierre
Please Log in or Create an account to join the conversation.
Ce quoi je vois surtout, c'est que vous avez des erreurs javascript sur votre page:
monosnap.com/file/E5Vx2XwoLZiwi6rMgmjM4F9OijMAne
L'une vient d'un conflit de jquery. Il faudrait voir pour mettre l'extension jQuery Easy sur votre site pour corriger cela.
Quant à la seconde erreur, cela vient d'une autre extension ( votre template ? ) qui rajoute le javascript de recaptcha sur la page:
monosnap.com/file/w6wty2PQujGyC86PRQCmOEyOL41Luv
Du coup cela vous fait 2 recaptcha d'ajouté sur la page, un par HikaShop et un par l'autre extension et cela créé cette erreur. Vu que l'autre ne sert à rien, il faudrait l'enlever.
Please Log in or Create an account to join the conversation.
Je suis un peu désemparé car, lorsque je désactive le plugin ReCaptcha v2 de Hikashop, je ne trouve plus d'appel au second recaptcha. Et d'ailleurs je ne vois pas d'où il viendrait vu que je ne crois pas avoir d'autre extension qui appelle ce recaptcha (?)
Ce qui me déroute, c'est pourquoi cela fonctionnait jusqu'à récemment et plus maintenant ?
La seule modif que j'ai faite sur le site, c'est installer J2xml pour préparer l'export de mes utilisateurs vers une nouvelle version de joomla. Je l'ai désinstallé mais cela ne change rien.
Sinon, le message de la console admin de google captcha renvoie vers cette page
Pour jquery, j'ai installé l'extension mais si j'active jquery dedans, des éléments (diapo en accueil par exemple) ne fonctionnent plus, ce qui me fait hésiter quant aux réglages à effectuer.
Merci déjà de vous pencher sur mon problème.
Please Log in or Create an account to join the conversation.
Il est normal que vous ayez cette erreur sur la console de google captcha.
Vu que le recaptcha n'est pas initilialisé à cause de l'erreur javascript, le plugin ne reçoit pas le token qui permet ensuite de vérifier la réponse auprès du serveur de recaptcha pour valider l'enregistrement.
Donc la cause, c'est l'erreur javascript et votre erreur dans la console google captcha n'est que la conséquence.
Je n'ai pas d'autre idées. Je vois que vous avez enlevé le plugin sur le lien que vous aviez fourni. Du coup je n'ai pas pu vérifier la situation une seconde fois histoire d'avoir plus d'idées sur des solutions potentielles.
Please Log in or Create an account to join the conversation.
je ne peux pas vraiment laisser en permanence ce problème, sinon cela bloque la création de comptes et les commandes ; mais sur un créneau à me préciser, oui.
Je viens d'essayer d'activer le plugin en le cochant pour le formulaire de contact mais pas pour le formulaire d'enregistrement et cela le laisse activé pour le formulaire d'enregistrement ! Alors que si j'essaye le contraire, ça le désactive bien pour le formulaire de contact. Est-ce que cela pourrait aider à cibler le problème ?
Enfin, dans gestion des plugins, à la ligne de Hikashop ReCaptcha v2, j'ai {__PLUGIN_VERSION__} et {__DAY__} {__MONTH__} {__YEAR__} au lieu des numéros et date ad-hoc. En soit ce n'est pas gênant, mais est-ce normal ?
Merci
Please Log in or Create an account to join the conversation.
1. Dans ce cas, merci de fournir un accès backend avec un lien vers ce sujet via notre formulaire de contact:
www.hikashop.com/support/contact-us.html
Comme cela, nous pourrons regarder le soucis à notre convenance en impactant le moins possible vos utilisateurs.
2. Pas de soucis pour le numéro de version. C'est juste que nous n'avons pas changé les numéros dans le XML du plugin.
Please Log in or Create an account to join the conversation.
Téléchargez à nouveau le paquet d'installation du plugin recaptcha sur notre site et installez-le à nouveau sur le votre.
Si cela n'aide pas, il nous faudra un accès FTP pour pouvoir analyser le soucis plus en détails.
Please Log in or Create an account to join the conversation.
hélas après application du plugin retéléchargé ici , le problème persiste.
Je vous ai envoyé les codes en MP, merci beaucoup.
Pierre
Please Log in or Create an account to join the conversation.
Bon j'ai cherché plusieurs heures cette après-midi mais je n'ai pas réussi à comprendre pourquoi il y a cette erreur.
Tout à l'air d'être bien configuré et initialisé par le plugin.
Mais recaptcha ne trouve pas le div d'initialisation (or il est bien là).
Il n'y a pas d'autre javascript recaptcha sur la page.
Les clés public/privée sont correctes.
Bref je ne vois pas. J'ai écumé les recherches google sur le sujet mais je n'ai rien trouvé qui pourrait m'aider. Je n'ai pas d'autre idée.
Please Log in or Create an account to join the conversation.
Je suis vraiment désolé que cela vous ait demandé tout ce temps, de surcroît un 1er mai...
D'un côté je suis "rassuré" qu'il ne s'agisse pas d'un banal problème de config que j'aurais pu régler seul, d'un autre je regrette que ce problème persiste. Il ne me reste plus qu'à bosser dur sur la migration vers J!3.9...
Est-ce que cela pourrait être dû à mon hébergeur OVH ? ou au htaccess ? Vous parliez d'erreurs javascript ou de conflits avec jquery, finalement ce n'est pas en cause ?
Bon en tout cas un très grand merci pour votre précieux support.
Please Log in or Create an account to join the conversation.
J'ai vu que vous aviez une erreur javascript dûe à votre template, donc je pensais que ça pouvait être lié, mais j'ai testé avec le template "test" de votre site, et l'erreur javascript disparaît mais le soucis avec recaptcha reste, donc ça ne vient pas de là.
Je ne pense pas que ce soit lié à Joomla, l'hébergement ou le htaccess.
Je ne sais pas
Please Log in or Create an account to join the conversation.
J'ai posté le soucis sur stackoverflow, et quelqu'un a répondu en mentionnant que le soucis vient probablement de mootools chargé sur la page:
stackoverflow.com/questions/61615590/unc...ust-be-an-element-or
Vu que vous utilisez Joomla 2.5, mootools est normalement utilisé pour pas mal de chose sur le frontend, ce qui explique le soucis.
Du coup, je crains qu'il ne vous reste pas trop d'options:
- passer sur Joomla 3
- utiliser un autre plugin de captcha ( par exemple: extensions.joomla.org/extension/access-a...security/keycaptcha/ )
Please Log in or Create an account to join the conversation.
merci pour ce retour et cette alternative.
J'ai essayé keycaptcha mais il n'apparaît pas en version mobile : y aurait-il d'autres plugins de captcha qui pourraient fonctionner sur le formulaire d'enregistrement joomla/hikashop ?
Encore merci
Please Log in or Create an account to join the conversation.
Pour HikaShop non.
Pour Joomla, vous avez le plugin de captcha par défaut (s'il existe sous joomla 2.5 ?).
Please Log in or Create an account to join the conversation.