Stripe - Requirement for Strong Customer Authentication

  • Posts: 23612
  • Thank you received: 3666
  • MODERATOR
1 week 3 days ago #309832

Hello,

@bonzomedia There is no Stripe plugin in HikaShop packages.
I can't say precisely but I suppose that the Stripe v2 plugin will become deprecated if Stripe deactivate that API.

@nmanek Yes, that thread is about the Stripe V3 plugin and the update will come as soon as possible ; the Payment Intent will provide the SCA requirement. Like I wrote several time in that thread, the API used by the plugin will not be compatible with SCA for Stripe. They made the "payment intent" but the API was in beta and they pushed it not so long ago to have their SCA support.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
1 week 2 days ago #309853

@ Jérôme : i'm a little bit confused now as I bought the V3 Stripe plugin in order to be online with the SCA request, and following this thread and you're last answer, i'm lost. What should i do ? wait the update you're talking before ?
Is this plugin ready for SCA ?

Thanks a lot

Please Log in or Create an account to join the conversation.

  • Posts: 23612
  • Thank you received: 3666
  • MODERATOR
1 week 2 days ago #309872

Hello,

We will make an announce when the plugin would be updated.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 124
  • Thank you received: 7
1 week 1 day ago #309902

Jerome wrote: @bonzomedia There is no Stripe plugin in HikaShop packages.,


That is complete disingenuous. At the time I selected and purchased Hikashop as a long term development commitment it WAS included. At some point in time you removed it and moved it's availability over to GitHub and made it available there for FREE.

You seem incapable of directly answering important questions, and you are creating confusion by not doing so in an accurate a precise manner, it seems you are deliberately avoiding providing answers less than 1 month away from Stripe's deadline. This is unprofessional, my clients are in a situation where they will potentially lose income.

1. When? We need a release date urgently for an SCA compliant Stripe payment gateway for Hikashop.
2. Where? Where will it be available from - Hikashop or some other third party?
3. Cost? This was of course originally included in the Hikashop subscription, it should be free, but if not how much?

Nicholas, please step in, we are not getting the answers that we require.

Please Log in or Create an account to join the conversation.

  • Posts: 23612
  • Thank you received: 3666
  • MODERATOR
1 week 1 day ago #309906

Hello,

Stripe v2 has been removed from HikaShop package as other payment plugins which have not been developed by the HikaShop team.
Yes, these plugins were moved to github and Stripe v2 is not the only one.
For the past years, the Stripe plugin is not in HikaShop packages ; that is the current situation.

I'm trying to work on the plugin right now, but each time I need to perform a reply and explain the same thing again, I loose some time and afterwards, I need to re-concentrate on the plugin development.

So, if you really want to have a plugin in time, please let me work on that.


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 226
  • Thank you received: 11
  • Hikashop Essential
1 week 12 hours ago #309926

Seems to me that this is a grey area at the moment. The information from Stripe updated 2 days ago is on the link below.

support.stripe.com/questions/strong-cust...sca-enforcement-date

BTW, if the card details are not collected on the website in Hikashop but you are directed to Stripe then is V3 required?

Dave B)

Last edit: 1 week 12 hours ago by davec. Reason: Additional query!

Please Log in or Create an account to join the conversation.

  • Posts: 23612
  • Thank you received: 3666
  • MODERATOR
1 week 1 hour ago #309951

Hello,

Stripe v3 is using the version 3 of the API (including JavaScript).
It is also called "Stripe Elements" ; and it's a form which is dynamically generated by the Stripe JavaScript and allow to send the credit card details to the Stripe platform which will give a "token" in return.
That token is received by the plugin (and HikaShop), so it do not store any credit card details (but since you have a form where the customer enter its credit card, you must have HTTPS for security purposes).

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Time to create page: 0.079 seconds
Powered by Kunena Forum