- Posts: 4820
- Thank you received: 654
ShipStation
Hello,
I didn't see your screenshot...
Can you post it on the forum And give me more elements?
You say that "it's not pulling in the orders", what did you mean?
Did you check in your Shipstation setting page that orders must be updated?
Regards,
Please Log in or Create an account to join the conversation.
I have make a fix, you can download the new version here
Just install it (like the first time, that will update your Shipstation plugin) and if I'm right the trouble will be solve!
Regards,
Please Log in or Create an account to join the conversation.
We installed the new version you provided. The error message went away but the order still not connect to Shipstation. Also, since we installed the plugin a new issue has showed up. In Paypal, the city says "false' (in Hikashop the city information is correct).
Can we hire you to just login to the site and Shipstation to get Shipstation working and fix the city 'false' issue?
thank you
Please Log in or Create an account to join the conversation.
You must join some screenshot, and more informations, because I don't understand where and how your issue appear.
For now it's not sure that the trouble can be fix from your website configuration.
Beside this, please note that a new version of the plugin is out from now, and this last version add a new option, so go back to the tutorial : here
Regards,
Please Log in or Create an account to join the conversation.
Below are errors we found at colostrumtherapy.com/index.php?option=co...hop&ctrl=shipstation
Notice: Undefined offset: 1 in /home/colos/public_html/plugins/system/shipstation/shipstation.php on line 173
Notice: Undefined offset: 1 in /home/colos/public_html/plugins/system/shipstation/shipstation.php on line 178
===
Please note that we have a standard Hikashop config with only 10 products and no custom plugins, etc., and are willing to pay anyone to help us. We have been patiently asking for help for a long time but now my boss is getting impatient and we may have to switch to another cart as he is using Shipstation for all his other websites and he loves it very much.
I will PM the login details and pray that you try to fix the issue. Again, we would be happy to pay for your time.
Please Log in or Create an account to join the conversation.
These notices are not linked to the problem.
You see them because you try to access the URL directly which is not the case with ShipStation which adds additional parameters to it. We'll remove the notices next week, but it won't help you.
As Jerome and Philippe told you before, the problem is not with the ShipStation plugin or HikaShop or the way you configured it.
The problem is the fact that your website is not accessible to anyone.
When I try to look at that URL, I don't get these notices, I get the same error philippe gave you before which is that the website is not accessible.
And if your website is not accessible, ShipStation cannot contact it in order to get the orders.
What you need to do is to fix the fact that your website is not accessible. Regardless how much you pay us, how many times you ask us, or if you use another cart solution, you will still have the exact same problem with ShipStation until you make your website accessible. If you don't know why your website is not accessible, I would recommend you to contact your hosting company so that they can check it.
Please Log in or Create an account to join the conversation.
We have programmers around the world work on the site without issues once they email us their IP.
Please go to whereismyip.com and we will then whitelist your IP. You can PM the IP if you wish.
Thank you
Please Log in or Create an account to join the conversation.
Send us all our references, for your website/administrator, your ftp, and your shipstation setting page references.
I sent my IP to you by mail.
Regards,
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
I proceed to some test, but unfortunately I can't be sure that's everything is okey, now we must wait for an action from ShipStation.
So, give me some news about my change.
An advice, check your plugin configuration, I think I respect it but check is better.
Regards,
Please Log in or Create an account to join the conversation.
- Posts: 3
- Thank you received: 0
We are encountering and error:
An error occurred attempting to update orders: Error in XML. Reason: The 'OrderDate' element is invalid - The value 'Nov/09/2015 15:49' is invalid according to its datatype 'DateTime' - The Pattern constraint failed.
Can you please help?
Please Log in or Create an account to join the conversation.
We are working to solve on this issue, and for this we are working with Shipstation support.
Be aware that when there is something new, we will tell you on this forum.
Regards,
Please Log in or Create an account to join the conversation.
- Posts: 3
- Thank you received: 0
Thanks,
Please Log in or Create an account to join the conversation.
Look, I sent several message to Shipstation support in order to solve this issue, and to tell you the truth... it's difficult to have the solution...
And so, if you feel able to solve it, of course you can! I have just one thing to ask, give me the solution at the end!
If you need some element or can help just tell me,
Regards,
Please Log in or Create an account to join the conversation.
- Posts: 5
- Thank you received: 0
I am a developer engaged by nevosolutions to help him solve his issue with the shipstation xml. The fix is actually pretty straight forward, and there was one other fix that was also required in order to have everything work properly. In the end, we were able to send a bunch of orders over to shipstation.
So, for the date format issue:
ShipStation requires a very specific date format that can be found in their XSD definitions.
<xs:element type="DateTime" name="OrderDate"/>
<xs:element type="DateTime" name="LastModified"/>
They are not using the standard XML datetime type definition, and instead, are using the following simple type:
<xs:simpleType name="DateTime">
<xs:restriction base="xs:string">
<xs:pattern value="[0-9][0-9]?/[0-9][0-9]?/[0-9][0-9][0-9]?[0-9]? [0-9][0-9]?:[0-9][0-9]?
[0-9]?[0-9]?.?[aApP]?[mM]?"/>
</xs:restriction>
</xs:simpleType>
This means they want a format that looks like: MM/DD/YYYY HH:MM:SS.
If I remember correctly, you were using 'M/d/Y H:i' as your date format string. This would give you a date that could look like the following:
Sep/11/2015 09:00
or
Dec/11/2015 12:55
Neither of these satisfy the requirements for the simpleType listed above. If you change your date formatting string to: m/d/Y H:i:s you will get:
09/11/2015 09:00:00
or
12/11/2015 12:55:00
Both of which do satisfy their simple type, and are accepted.
Please Log in or Create an account to join the conversation.
- Posts: 5
- Thank you received: 0
The country code that is currently being passed by the shipstation plugin looks like this: country_United_States_Of_America_243
Shipstation requires that country code by a 2 letter representation of the country.
I solved this by loading the zones (very similar to how addresses are being loaded by the plugin) with the array keyed on 'zone_namekey'.
I then use $zone =& $zones[$address] after we have snagged the address out of the addresses array, in order to get the proper zone object.
In the xml, I do $zone->zone_code_2 where you are currently using $address->address_country.
With these two fairly simple changes, I was able to export orders for two different stores to shipstation, with no hiccups at all.
Please Log in or Create an account to join the conversation.
Thanks to you, I was able to correct the Xml format, really: thank you!
For everyone, you will find with this message the new Shipstation version that will correct the issue which we all speak too much.
I will just add to this, sorry for the delay.
Regards
Please log in or register to see it.
Please Log in or Create an account to join the conversation.
I edit my previous email file with a corrected bug fix.
Regards,
Please Log in or Create an account to join the conversation.
An error occurred attempting to update orders: Error in XML. Reason: The 'OrderDate' element is invalid - The value 'Oct/13/2015 03:19:38' is invalid according to its datatype 'DateTime' - The Pattern constraint failed.
Please Log in or Create an account to join the conversation.
- Posts: 5
- Thank you received: 0
Given the format your error shows, it looks like you aren't using the attached version.
The attached version has the correct timestamp format (that I am using in a live install) of 'm/d/Y H:i:s'
This would produce a date that looks like '10/13/2015 03:19:38'. The format your error shows is the old format from prior to the fix. I would try replacing your file with the version attached to the forum (incase they have not released this on the download page, as of yet)
Please Log in or Create an account to join the conversation.