Bug when adding a address

  • Posts: 137
  • Thank you received: 2
11 years 3 months ago #10822

Hi!

We use the Business Edition of Hikashop with Joomla 1.6 and the yoo_phoenix template.

When adding a new address during the checkout process we get a bug, see attached file.

The address form is displayed twice.

Best regards

Attachments:
Last edit: 11 years 3 months ago by emergentec.

Please Log in or Create an account to join the conversation.

  • Posts: 75861
  • Thank you received: 11845
  • MODERATOR
11 years 3 months ago #10845

Hi,

This is a bug which happened before version 1.4.5 of HikaShop on joomla 1.6. Do you use the latest version ? Otherwise, could you update and try again ?

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
11 years 3 months ago #10942

I updated to the latest version 1.4.7 and still have the problem!

Please Log in or Create an account to join the conversation.

  • Posts: 75861
  • Thank you received: 11845
  • MODERATOR
11 years 3 months ago #10948

We cannot reproduce the problem on our end. Could you give a link to your website so that we can check on the problem ?

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
11 years 3 months ago #11402

As our system is not yet deployed I can't give you a link

Please Log in or Create an account to join the conversation.

  • Posts: 75861
  • Thank you received: 11845
  • MODERATOR
11 years 3 months ago #11412

As we can't reproduce the problem on our end, we will have to wait for you to deploy it then in order to help you.

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
11 years 4 days ago #20081

As we are heading to a new version of our product, we still have the bug that when adding a new address during the checkout process, the form is displayed twice. see attached screenshot

additionally I would like to know, if it is possible to display certain fields like "accept Terms of Use" only during the registration process and not anymore when editing an address or adding a new address.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 75861
  • Thank you received: 11845
  • MODERATOR
11 years 4 days ago #20107

Do you have your website online. We still cannot reproduce the problem on our end.

For the terms and conditions, you could just hide the line of the form with CSS.

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
10 years 11 months ago #20855

nicolas wrote:

Do you have your website online. We still cannot reproduce the problem on our end.
For the terms and conditions, you could just hide the line of the form with CSS.

We solved this problem by removing the option to delete an address, just editing the address is good enough.

Hiding the line with CSS works well in most browsers, but not in IE9. Is there another possibility to hide specific lines (actually <tr>s)?

Please Log in or Create an account to join the conversation.

  • Posts: 75861
  • Thank you received: 11845
  • MODERATOR
10 years 11 months ago #20867

You should be able to hide the lines for any browser with the display:'none'; CSS property.

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
10 years 11 months ago #20870

.hikashop_registration_address_vat_line{ /* Do not display VAT lable & input on registration */
display:none;
}

In IE9 I can still see the <tr>

Please Log in or Create an account to join the conversation.

  • Posts: 75861
  • Thank you received: 11845
  • MODERATOR
10 years 11 months ago #20877

Then maybe your template overrides it so you could try with that CSS:
.hikashop_registration_address_vat_line{
display:none !important;
}

Also, don't forget to clean your browser's cache when testing, otherwise, it won't retrieve the new CSS.

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum