Product search module does not work

  • Posts: 36
  • Thank you received: 0
11 years 6 months ago #1360

Hi,

It seems that searching for products does not yield any results. Product searching worked perfectly in the previous version of Hikashop, but for some reason the search function can't find any of my products in this version.

If someone could help me solve this issue, I would be very happy. :)
-Redeemer

Please Log in or Create an account to join the conversation.

  • Posts: 75529
  • Thank you received: 11766
  • MODERATOR
11 years 6 months ago #1365

Is the product search plugin published ?
I see no reason why it wouldn't work on the new version if it worked on the previous.

Last edit: 11 years 6 months ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 0
11 years 6 months ago #1366

Yes, both the category search and product search plugins are published.

This is strange, since the product search plugin worked perfectly before I updated Hikashop...

I'll try disabling and then reenabling the search plugin.

EDIT: Hmm, that didn't work. Do you have any ideas?

Last edit: 11 years 6 months ago by Redeemer.

Please Log in or Create an account to join the conversation.

  • Posts: 75529
  • Thank you received: 11766
  • MODERATOR
11 years 6 months ago #1367

Something you could try is to activate the debug mode of Joomla and look at the queries at the bottom of the page after a search. Look at the ones on the table hikashop_product and see if any of them contains your search string. If not, then the problem lies in the fact that joomla can't trigger the plugin for whatever reason. If yes, then maybe there is an error in the search query in some circumstances ?

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 0
11 years 6 months ago #1371

Here's one of the queries Joomla spat out after I performed a search for "ammo" (without the quotes):

SELECT  a.product_id AS id, a.product_name AS title, a.product_created AS created , a.product_description AS text, "1" AS browsernav
  FROM jos_hikashop_product AS a
  WHERE a.product_published=1
  AND a.product_type='main'
  AND ((a.product_name LIKE '%ammo%')) OR ((a.product_description LIKE '%ammo%'))
  ORDER BY a.product_modified DESC
  LIMIT 0, 50
It looks to me like Joomla triggered the plugin fine... I can see my search string in there.

Please Log in or Create an account to join the conversation.

  • Posts: 75529
  • Thank you received: 11766
  • MODERATOR
11 years 6 months ago #1376

The query is good too. I don't see any reasons why it wouldn't work if it goes that far.

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 0
11 years 6 months ago #1382

Yes, it's very strange. The products don't show up at all in the results list.

If you guys could look into this matter further, I would be much obliged. Don't worry, I'm prepared to wait. ;)

Please Log in or Create an account to join the conversation.

  • Posts: 75529
  • Thank you received: 11766
  • MODERATOR
11 years 6 months ago #1384

Sure, but we can't fix something which works for us. The only way we could would be to either be able to reproduce the problem on our test website, or have access to your website (+ FTP). But since we can't do both, we can't look at the problem :/

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 0
11 years 6 months ago #1390

Well, this is embarrassing.

The word I was searching for never brought up any products because that word wasn't in the name or the description of any of my products.

Sorry for wasting so much of your time. :(
-Redeemer

Please Log in or Create an account to join the conversation.

  • Posts: 75529
  • Thank you received: 11766
  • MODERATOR
11 years 6 months ago #1391

Great, at least there is no bug :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.070 seconds
Powered by Kunena Forum