Missing error message during registration process

  • Posts: 137
  • Thank you received: 2
11 years 4 months ago #13825

Hi!

We use the hikashop form for the registration of our users. When we use a e-mail address which is already registered we only get the error message: undefined

Where can we edit this?

Best regards

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 4 months ago #13828

Hi,

No idea. Could you give more information about the problem ? Are you on joomla 1.5 or 1.6 ? How is that message displayed (screenshot?) ? What value did you select for the "registration" option of the checkout tab of the config ?

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
11 years 3 months ago #13948

I figured out this happens if you write letters into the field telephone! Joomla 1.6

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 3 months ago #13949

We don't have that error on our end. Did you update HikaShop at one point ? If so, did you update the translation file as well ?

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
11 years 2 months ago #16627

nicolas wrote:

We don't have that error on our end. Did you update HikaShop at one point ? If so, did you update the translation file as well ?

You can verify this problem at bio.emergentec.com . We already updated HikaShop during the development. Where or how can we update the translation file?

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 2 months ago #16629

I'm getting an error message when registering with an email which is already registered:
The e-mail provided is already registered with BIO. Please either select ‚forgot password‘ at BIO home, or contact This email address is being protected from spambots. You need JavaScript enabled to view it. in case of questions.

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
11 years 2 months ago #16690

At the moment we get the error message "undefined" when you enter non-numeric characters into the field "telephone"!

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 2 months ago #16691

Did you update your translation file when updating HikaShop ? Because it's highly probable that the translation for the error message is missing in your translation file.

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Thank you received: 2
11 years 2 months ago #16802

I just updated the english language file, but the problem is still there! You can verify it at bio.emergentec.com at "create your BIO account"

Which error message should appear by default?

Last edit: 11 years 2 months ago by emergentec. Reason: added "create your BIO account"

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 2 months ago #16812

I see that you also have an old version of HikaShop. Could you also update HikaShop to the latest version. I see that you don't have the correct javascript added to your page in order to handle the telephone field check.

Please Log in or Create an account to join the conversation.

Time to create page: 0.067 seconds
Powered by Kunena Forum