Products and Characteristics

  • Posts: 11
  • Thank you received: 0
11 years 2 months ago #14510

When I define a product and add a characteristic to that product, I can save this. Later on, when I change the characteristic, I am no longer able to save the product. What I get is "Product with the same code still exists. Save Error"

What do I do wrong or how to solve that.

Kind regards

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11830
  • MODERATOR
11 years 2 months ago #14535

You can only have one product (or variant) with a specific product code. If you get that error, it's because you have already a product/variant with the same name as the product saved (or the variants generated).

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
11 years 2 months ago #14568

Right. But what if I change now one of the variants. Lets say I have a product table and the variants are green, yellow and gray. If I change now gray to black.

In this case I do have a product/variant with table/yellow and table/green.

How to deal with this?

And what exactly it the code? Is this the product code? As I understand, the ID's are taken in the database tables.


I even can not change anything in the description, I can not assign nor delete categories and characteristics. Which means: I am not able to change anything.

Kind regards

Wolfgang

Last edit: 11 years 2 months ago by Wolfgang.

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11830
  • MODERATOR
11 years 2 months ago #14575

You need to click on the "manage variants" button of your product. You will see the list of variants and you will be able to unpublish/delete the ones you don't need and/or add ones you're missing.

Yes, the code is the product code. If you can't save a product, it's either because the code of the product already exists or the code of a variant of the product already exist. Changing them should solve the problem...

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
11 years 2 months ago #14577

I did this. If I click on manage variants, I get the same Error. As I said before, I can not change anything. Click on Delete Characteristic, Delete Category, Edit the text or change "Disply contact button on product page" leads me to this error too.

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11830
  • MODERATOR
11 years 2 months ago #14580

Could you try to activate the joomla debug mode in the joomla configuration and try again ?

Do you get additional error messages ?

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
11 years 2 months ago #14581

This is what I get:

JDatabaseMySQL::query: 1054 - Unknown column 'product_contact' in 'field list' SQL=UPDATE `itvp_hikashop_product` SET `product_name`='Installation und Konfiguration von Windows 7 Clients',`product_url`='www.microsoft.com',`product_meta_description`='MOC 6292, MOC6292, 070-680, 70-680, 070680, 70680 Installation und Konfiguration von Windows 7 Clients,',`product_keywords`='MOC6292',`product_code`='MOC6292',`product_tax_id`='21',`product_sale_start`='',`product_sale_end`='',`product_contact`='0',`product_quantity`='-1',`product_min_per_order`='0',`product_max_per_order`='0',`product_weight`='0.000',`product_weight_unit`='kg',`product_length`='0.000',`product_width`='0.000',`product_dimension_unit`='m',`product_height`='0.000',`product_published`='1',`product_access`='all',`product_group_after_purchase`='',`product_type`='main',`product_description`='

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11830
  • MODERATOR
11 years 2 months ago #14582

Ok. That's another problem then.

Normally, if you update to version 1.4.9 of HikaShop, that should solve the problem automatically.
Otherwise, that solution will do it: www.hikashop.com/support/forum/3-bug-rep...t.html?lang=en#12117

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
11 years 2 months ago #14586

Looks good, I think that's it.
Thank you.

Kind regards

Wolfgang

Please Log in or Create an account to join the conversation.

Time to create page: 0.052 seconds
Powered by Kunena Forum