Modules dissappearing.

  • Posts: 59
  • Thank you received: 0
13 years 3 months ago #2033

If I click onto a product diplayed in the central page column, all work fine when the product page is loaded. But if I click onto a product that is displayed in a side module, when the product page appears, left side category modules dissappear.

You can try at: shoptest.avaray.com/en/mujer-venezuela

Please Log in or Create an account to join the conversation.

  • Posts: 81182
  • Thank you received: 12995
  • MODERATOR
13 years 3 months ago #2035

That's a problem of Itemid.
In joomla, each menu generated has an Itemid linked to it. When you assign a module to a menu, in fact, all the links with the parameter Itemid equal to the menu Itemid will display that module.

At first, we didn't had any Itemid in our links in HikaShop. Now HikaShop always adds the Itemid parameter the urls so that you keep your modules while navigating your store.
However, it depends on the options you set in your menus and modules.
For modules displaying a list of product and which are not synchronized with the option "content synchronization", the Itemid used will be the Itemid of the menu you can set in the options of the module.
For modules displaying a list of category, the itemid used will be the itemid of the menu you can set in the options of the module.

In all other cases, the links will keep the Itemid of the current page so you will keep the current modules.

So to conclude, it means that you should make sure that you are using at least the version 1.3.0 and that your modules have the option "menu" set to the appropriate value.

Please Log in or Create an account to join the conversation.

  • Posts: 59
  • Thank you received: 0
13 years 3 months ago #2051

Truly, i don´t know what to do with your information.

Yes, we are using a version newer than 1.3.0.

I can´t undertand yet where the problem regarding itemid would be in my page. If it is server as help, the modules that disappear are hikashop categories modules, correctly linked to their hikashop menu items (as we together verified in a preovious post). I repeat that those modules are erased only after cliking on a product displayed in a product module (which are suppossed that not need to be linked to a menu item) at right side of the page. I tried to activate "content synchronization" in modules and menus involved and got nothing.

Last edit: 13 years 3 months ago by Avaray.

Please Log in or Create an account to join the conversation.

  • Posts: 81182
  • Thank you received: 12995
  • MODERATOR
13 years 3 months ago #2055

Did you set the module which disappear to appear only on certain pages on the joomla options of the module ? If yes, then, in the HikaShop options of the module where you click on the product, you need to set the menu option to one of the pages to which you limited the other module.
Otherwise, it could be that the module which disappear has the option "content synchronization" to on, so you should turn it off.

Please Log in or Create an account to join the conversation.

  • Posts: 59
  • Thank you received: 0
13 years 3 months ago #2083

Ok. I set the menu ooptions to one of the pages limited by the other module, and seem that it works. But, i am sorry, from an user point of view, it is nonesense for me.

By the other way, i found what looks like a new bug. Through my web construction, i created and erased a lot of menu items that were definitively erased from the menu bin (i checked that it is completely empty). But now in the menu options of my hikashop modules, they have come back as you can see at the picture attached.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 81182
  • Thank you received: 12995
  • MODERATOR
13 years 3 months ago #2085

Yes, it's indeed not easy to setup. Unfortunately, that's how joomla works...
We want to provide in the future preconfigured modules and menus so that you don't have to configure all that by yourself which should already greatly simplify the process.

For the menus appearing although your removed them, I just checked on a test website and after removing the menu and then removing it from the bin menu, I couldn't see it anymore in that dropdown. The menus displayed in that dropdown come from the joomla menu table. IF they are displayed there, it means that there are still in the joomla menu table... There is nothing we can do about it :/

Please Log in or Create an account to join the conversation.

  • Posts: 59
  • Thank you received: 0
13 years 3 months ago #2302

After your last response, all started to work properly. I though that this issue was closed, but has re-emerged in another way: If I proceed to checkout, those left-side category modules again disappear despite i set them as you told me before.

Please Log in or Create an account to join the conversation.

  • Posts: 81182
  • Thank you received: 12995
  • MODERATOR
13 years 3 months ago #2316

Normally, on the latest versions of HikaShop, we added some code to set the itemid in the URL for the checkout. Maybe you have edited that view ?

Could you check on the Display->Views menu for the cart file of the view product if you have a customization ?

If so, you can either delete the customization, but you will loose your changes, or try to modify the code:
We added the code :
global $Itemid;
$url_itemid='';
if(!empty($Itemid)){
$url_itemid='&Itemid='.$Itemid;
}
near the beginning of the file and then, we change the form action URL to add the .$url_itemid at the end:
echo hikashop::completeLink('product&task=updatecart'.$url_itemid,false,true);
and at the end of the checkout button URL:
hikashop::completeLink('checkout'.$url_itemid)

Please Log in or Create an account to join the conversation.

Time to create page: 0.077 seconds
Powered by Kunena Forum