Product Import Bug in Joomla 1.6

  • Posts: 41
  • Thank you received: 1
10 years 11 months ago #21143

Hi there,

Would like to join the others in thanking you for this product. I'm developing my first site with HikaShop after years of using others, and so far have liked what I've seen.

With the site I'm developing, I'm migrating the several hundred products from another shopping cart, and the import process is working well, but I think I've found a bug.

The bug doesn't stop the import process but it throws an error message saying:

"The column 'price_quantity' is not in the list of possible columns"

I've had a look through phpMyAdmin and can see in the _hikashop_price table that there is a "price_min_quantity" which I'm guessing is the right one - odd that it get's exported as "price_quantity" though.

Anyway, not a problem for me as such, but thought I'd let you know.

Cheers

Nathan

Joomla 1.6.3
HikaShop 1.5.2

Last edit: 10 years 11 months ago by nathan.

Please Log in or Create an account to join the conversation.

  • Posts: 75858
  • Thank you received: 11839
  • MODERATOR
10 years 11 months ago #21151

Hi,

Thank you for the report. Indeed, the column name should be price_min_quantity and not price_quantity. We'll fix that for next release.

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
10 years 11 months ago #21153

No problem, just while i'm on a roll...

I've just completed my major import and it all went fine except the completed import message is a bit odd...

443 products found : 0 new products imported, 0 invalid product code, 443 already existing products

They were all "new" products that I imported, not "already existing" one's so that could be confusing for some people.

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
10 years 11 months ago #21154

And one other thing, if I have a category in the import spreadsheet that has a comma or single quote in it's title, and I have it set to automatically create categories, the category gets split in to two....

Vol 30(6) 2005 - Lawyering, dissent and the surveillance state

becomes...

Vol 30(6) 2005 - Lawyering

and

dissent and the surveillance state

Is there a way of escaping special characters in the spreasheet?

Please Log in or Create an account to join the conversation.

  • Posts: 75858
  • Thank you received: 11839
  • MODERATOR
10 years 11 months ago #21159

If it says that the products already existed it means that the product codes were already in the product table. Maybe because you imported them twice in a row or something like that ?

We'll look at adding a \ to the commas in the export and ignore the comma if there is a \ before on the import so that it works properly for next version.

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
10 years 11 months ago #21162

Hmm, I'd like to say that's right about the product codes, but it was 443 products with unique codes that I hadn't imported yet.

Maybe the confirmation message has just got a language variable or something the wrong way around.

That's great about the improvement for commas.

Please Log in or Create an account to join the conversation.

  • Posts: 75858
  • Thank you received: 11839
  • MODERATOR
10 years 11 months ago #21175

The language variable is correct. I just tried to import two products on our demo website and got the message:
2 products found : 2 new products imported, 0 invalid product code, 0 already existing products

Then, when I tried a second time, I got the message:
2 products found : 0 new products imported, 0 invalid product code, 2 already existing products

So it seems to be working properly...

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 1
10 years 11 months ago #21176

I don't know - is the demo site running Joomla 1.6?

I can 100% guarantee I hadn't already imported them.

In fact, I've received that message on every fresh import I've done, which is about 4 now. On the last import I thought I'd copy the message and let you know.

But if you can't reproduce it, it's not a stress, I've got all my products imported now and it doesn't affect the process anyway, just thought it was odd.

Please Log in or Create an account to join the conversation.

  • Posts: 75858
  • Thank you received: 11839
  • MODERATOR
10 years 11 months ago #21179

The version of joomla it unrelated to the import and to the message. So I don't know what to say. As long as we can't reproduce the problem, it's hard to say anything, but thanks for letting us know.

Please Log in or Create an account to join the conversation.

Time to create page: 0.067 seconds
Powered by Kunena Forum