Products Not displaying on all pages

  • Posts: 94
  • Thank you received: 0
10 years 10 months ago #27340

So I think this is a bug and I sent an email about it just to be sure with my web address so that you guys can check it out.

Basically I have about 59 products in one of my categories. The first 40 show and the last 20 do not. The system splits it among 3 pages and page 1 and 2 have the correct products in order and then page 3 for some reason repeats the products from page 1?????

Then if I set it to show all products at the same time it displays them all (59) with no issues. Ideas?

Please help as this is a big problem.

Please Log in or Create an account to join the conversation.

  • Posts: 76147
  • Thank you received: 11918
  • MODERATOR
10 years 10 months ago #27342

Do you have the joomla cache activated ? If so you should disable it and try again.
Do you have the latest version of Hikashop ? If not, you should update and try again.

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 0
10 years 10 months ago #27343

nicolas wrote:

Do you have the joomla cache activated ? If so you should disable it and try again.
Do you have the latest version of Hikashop ? If not, you should update and try again.


Cache is off and has been for a while and also I just installed Hikashop yesturday so yes I have the latest version 1.5.4.

Ideas?

Please Log in or Create an account to join the conversation.

  • Posts: 76147
  • Thank you received: 11918
  • MODERATOR
10 years 10 months ago #27347

Did you deactivate both the cache in the config of joomla AND the cache plugin ?

Could you try to activate the debug mode of joomla in the configuration and give us any error message you might have on that listing as well as the traces displayed at the both of the page when you're on the third page ?

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 0
10 years 10 months ago #27353

nicolas wrote:

Did you deactivate both the cache in the config of joomla AND the cache plugin ?

Could you try to activate the debug mode of joomla in the configuration and give us any error message you might have on that listing as well as the traces displayed at the both of the page when you're on the third page ?


Ok I think I did both and did not see any errors. Can you maybe log into my admin panel and help me. I am sure it will take you 5 seconds to figure out what is wrong or if there is an error and where it would display. Can I PM you the login info?

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 0
10 years 10 months ago #27355

nicolas wrote:

Did you deactivate both the cache in the config of joomla AND the cache plugin ?

Could you try to activate the debug mode of joomla in the configuration and give us any error message you might have on that listing as well as the traces displayed at the both of the page when you're on the third page ?


So I believe I figured it out. All of the products had an order of 0 listed. As soon as I changed one product to 1 the rest of the products automatically assigned themselves an order and it works normally now. This has to be a bug. If you don't have an order assigned in the import CSV it will then list everything as 0 and Hikashop gets confused. Thoughts?

Please Log in or Create an account to join the conversation.

  • Posts: 76147
  • Thank you received: 11918
  • MODERATOR
10 years 10 months ago #27362

That would explain the problem. It's probably MySQL which gives random results when the products listing is ordered by the ordering column and that you didn't set any ordering for your products.
The solution should be easy: just order your products with another column like the product_id.
You can do that by editing the hikashop options of your products listing menu/module and changing the option "ordering column" to "product_id".

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 0
10 years 9 months ago #27562

Yeah I got it to work by just ordering the products...you may want to think about maybe editing the import process to fix this though...

Also on export it could be useful to allow for the selection of what fields you want exported... makes updating products easier. Just a suggestions. Love hikashop so far.

Please Log in or Create an account to join the conversation.

  • Posts: 76147
  • Thank you received: 11918
  • MODERATOR
10 years 9 months ago #27577

It is unfortunately done on purpose. You can't changing the ordering of all the products on the import. That would require to make at least one SQL query per product. And with more than a few hundreds products, the import would just crash the MySQL process. So the ordering is not set by default with you import products and we won't be able to change that.

Improving the import so that you can choose the fields is a neat idea. We'll add that to the todo list as a low priority.

Please Log in or Create an account to join the conversation.

Time to create page: 0.067 seconds
Powered by Kunena Forum