HTML bug

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
11 years 4 months ago #5537

There is a small html tag error in line 73 of /administrator/com_hikashop/views/category/tmpl/form.php

instead of

<input type="file" name="files[]" size="30"></input>

it should be
<input type="file" name="files[]" size="30" />

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
11 years 4 months ago #5538

Thanks. That will be corrected for next version.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
11 years 4 months ago #5540

Another error

/administrator/com_hikashop/views/product/tmpl/priceaccess.php

I believe the last two closing tags should be inverted so instead of:

<fieldset>

<form action="index.php?option=<?php echo HIKASHOP_COMPONENT ?>&amp;ctrl=product" method="post" name="adminForm" enctype="multipart/form-data">

	<legend><?php echo JText::_('ACCESS_LEVEL'); ?></legend>

	<?php 

	if(hikashop::level(2)){

		$acltype = hikashop::get('type.acl');

		echo $acltype->display('price_access',$this->access,'price');

	} ?> 

	</fieldset>

</form>

is should be
<fieldset>
<form action="index.php?option=<?php echo HIKASHOP_COMPONENT ?>&amp;ctrl=product" method="post" name="adminForm" enctype="multipart/form-data">
	<legend><?php echo JText::_('ACCESS_LEVEL'); ?></legend>
	<?php
	if(hikashop::level(2)){
		$acltype = hikashop::get('type.acl');
		echo $acltype->display('price_access',$this->access,'price');
	} ?>
</form>
</fieldset>

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
11 years 4 months ago #5541

Indeed. That's fixed on our end and will also be in next release.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
11 years 3 months ago #5608

line 159 for frontend_default.css

*display:inline;

should be without the *

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
11 years 3 months ago #5612

Thank you for that information. We will do so in next version.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
11 years 3 months ago #7507

Small error in the frontend_default.css (Business version 1.4.4 line 350)

.jpane-toggler span {v5px 50% no-repeat;padding-left:20px;font-weight:700;}

There should be not 'v' before 5px

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
11 years 3 months ago #7514

Thanks, we'll fix that.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
11 years 2 months ago #10040

Business 1.4.7. There is a small typo in the admin user class file. Instead of $this->cart_udpate you meant $this->cart_update

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
11 years 2 months ago #10047

Yes thanks. We'll fix that for next version.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
11 years 1 month ago #14427

In 1.4.9 Business alphauserpoints_configuration.php the opening and closing table tags are the wrong way round; in line 94 the closing div tag should be moved to line 99; after line 233 there is no opening tr tag; in line 246 or 248 there is an extra tr closing tag.

Last edit: 11 years 1 month ago by jameswadsworth.

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
11 years 1 month ago #14432

The table tags are in the good order as that file is included in a table. You can look at the other configuration.php files to see that they start directly with tr tags because they are called from within a table.
For the other two problems you reported, you are indeed correct. We corrected that on our end and we're going to do a new build of the current release ASAP.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
10 years 11 months ago #17797

Not really a bug, but in version 1.5.1 in many of the view.html.php admin files the $config is declared twice. For example in the user view.html.php file it is declared in line 102 and line 111.

In frontend/ views / user /tmpl / form.php in line 21 <?php is declared again breaking the script

Last edit: 10 years 11 months ago by jameswadsworth.

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
10 years 11 months ago #17802

Yes, it's because several people added code one after another..copy/paste.
Having $config several times is not a problem. It just uses a few cpu cycles for nothing but it's not important in comparison of improving a query or caching the result of a query.

Thank you for your second point. We fixed that and repackaged 1.5.1.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
10 years 7 months ago #26383

All versions up to and including 1.5.4. In the backend > views > order > tmpl > invoice.php line 35 width=100px should be width:100px

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
10 years 7 months ago #26397

Thanks. We'll change that.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
10 years 3 months ago #37511

In 1.5.6 in the ups shipping plugin in the file ups.php line 90 and 99 you might want to check the spelling of "warehouse". In line 165 I think you mean 'high' instead of 'higth'

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
10 years 3 months ago #37680

Thank you. We'll fix that for next release.

Please Log in or Create an account to join the conversation.

  • Posts: 272
  • Thank you received: 3
  • Hikashop Business
10 years 3 months ago #38037

The does not appear to be a translation in the language file of 'NO_MANUFACTURER' which is in the new manufacturerType file.

Also would it not be better to add a sort the return list of manufacturer names in line 15 of the same file:

$query = 'SELECT category_id,category_name FROM '.hikashop_table('category').' WHERE category_type = "manufacturer" AND category_depth != 1 ORDER BY category_name ASC'

Last edit: 10 years 3 months ago by jameswadsworth.

Please Log in or Create an account to join the conversation.

  • Posts: 75481
  • Thank you received: 11749
  • MODERATOR
10 years 3 months ago #38164

Thanks, we'll change that.

Please Log in or Create an account to join the conversation.

Time to create page: 0.055 seconds
Powered by Kunena Forum