Can't assign categories to products

  • Posts: 5
  • Thank you received: 0
11 years 7 months ago #676

Hi HikaShop Team,

I'm having a quite basic issue so I hope the solution is also basic :-)

When I create a new product, I'm not able to assign any category to it.
I couldn't find anything in the forum on the topic, apologies in advance if this is an obvious case of RTFM or if it was discussed here before...

Now the problem description:
I'm following the guidelines to assign a given product to a given category:
- Under product page / "Categories" section: click "add" button
- The list of categories pops up
- I check the category I want and click on "OK"
- Then, the category name is displayed in the popup window (but IE gives an "Error on this
page / Object doesn't support this property or method")
- back in the product page, the category is not assigned. IE gives again an "Error on this page / Object doesn't support this property or method".

I tried again and again with various ways : saving the product before / after / without saving / re-creating categories / products / etc. without success. Whatever I do, I can't assign a category to a product and only the root product category is (I believe, automatically), assigned when I save the product.

Not sure whether this could be due to my local setup, giving the info anyway:
OS: Win XP SP3
IE: 7.0.5730.11
Joomla: 1.5.21
PHP: 5.3.0 (also tried on 5.2.0 and 5.2.11)
Apache: 2.2.11
MySQL: 5.1.36

Thanks in advance for your help!

Cheers

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
11 years 7 months ago #678

Hang on... Just found out that I'm getting the same error on your demo site when trying to change the category of a product. Any idea? Could it be due to some IE setting?

Thanks!

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11830
  • MODERATOR
11 years 7 months ago #693

If you have the same problem on our demo website then, there is a problem between hikashop and your browser.
I tried myself on both IE 7 and IE 8 on windows vista and couldn't replicate the bug on our demo website. All I can think of is that there must be some setting/extension/toolbar on your IE which makes that problem occur.

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
11 years 7 months ago #774

Salut Nicolas
Thanks a lot for the quick reply!
Well, after a fair bit of testing I couldn't find any special IE settings so I reinstalled everything on another PC (Win 7 - IE 8) and it worked perfectly.

By looking at the "normal" behavior I understood the error a bit more:
- After clicking on "add" in the category section of the product page, the popup shows up. Ok.
- But then, when I choose a category in the popup, after clicking "ok" it displays the categories in the popup itself (rather than in the product page) and doesn't close the popup. Then I have to close the popup manually, and nothing is kept in the product page itself. The category list remains blank.

If it helps... Or if you have any clue of the IE settings (could it be something like preventing to run scripts that have an effect on another part/window?)

Cheers

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11830
  • MODERATOR
11 years 7 months ago #776

Hi Michel,

Well, if the javascript there doesn't work as it should, you should have a javascript error written somewhere. If that's the case, could you copy/paste it here ? That would really help in understanding the problem.
You can get javascript errors by following that article: www.testingreflections.com/node/view/4009

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
11 years 5 months ago #5262

Yeah, same problem here, can't enter a category for an item and, like the useless virtumart forums, no indication in this thread that it was solved or how it was solved...or not.

I've tried it in Firefox and IE and they both display the same behavior, no way to assign the category, at least no way that actually works.

Gonna be a deal breaker. I'm looking to replace four virtuemart installations that I'm tired of having to fix endlessly every time the script is updated or some little change is made somewhere and would be more than happy to pay a reasonable amount for a script that works and is supported. I'd hoped HikaShop was going to be it but if this basic problem with a basic part of entering an item is any indication, I'll keep looking.

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11830
  • MODERATOR
11 years 5 months ago #5263

Hi,

Again, we couldn't reproduce the problem on our end. It works with all our versions of IE, Firefox, Chrome, etc. Do you have a special template in your back end ?
Do you have a javascript error when that happen ?

Which version of HikaShop are you using ?

Are you sure that you checked the category checkbox and then clicked on the ok button ? If you just click on the category name, the system will display you the listing of the sub categories of the category you clicked on.

Please Log in or Create an account to join the conversation.

Time to create page: 0.070 seconds
Powered by Kunena Forum