Coupon Code not adding Shipping to final price

  • Posts: 45
  • Thank you received: 0
11 years 4 months ago #7022

Hi,

Sorry for being a pain. :blush:

I have created a test coupon which gives £3 discount. When I enter the coupon and click Add, I see the following:

Total £ 18.00
Coupon -£ 3.00
Shipping £ 3.99
Final total £ 15.00

It is not adding the shipping amount to the Final Total. However, when transferred to Paypal, the discount is showing and the Final amount is correct: £18.99

Please Log in or Create an account to join the conversation.

  • Posts: 75859
  • Thank you received: 11839
  • MODERATOR
11 years 4 months ago #7025

Hi,

I recall that other users had trouble with shipping not being added to the order in previous releases of HikaShop. Do you have the latest version of HikaShop ?
If yes, could you give the URL of your website so that we can have a look at the problem ?

Please Log in or Create an account to join the conversation.

  • Posts: 45
  • Thank you received: 0
11 years 4 months ago #7041

Yes I downloaded it today.. apologies I am working on localhost at moment so no url :( can anyone else confirm whether it is still a prob on latest version?

this is the version I have: com_hikashop_starter_1.4.4_2011-02-05

Please Log in or Create an account to join the conversation.

  • Posts: 75859
  • Thank you received: 11839
  • MODERATOR
11 years 4 months ago #7042

Well, are you able to reproduce the problem on our demo website ?
If so, then it should be easy for us to reproduce the problem...

Please Log in or Create an account to join the conversation.

  • Posts: 45
  • Thank you received: 0
11 years 4 months ago #7069

Yes, just tried it on demo site. created coupon code 1234 and then on checkout entered 1234 as coupon and total is shown as:

Total 200,00 €
Coupon -3,00 €
Shipping 50,00 €
Final total 197,00 €

should really be: 147,00

Please Log in or Create an account to join the conversation.

  • Posts: 75859
  • Thank you received: 11839
  • MODERATOR
11 years 4 months ago #7077

Ok. Thank you. We're going to review the problem and come back to you.

Please Log in or Create an account to join the conversation.

  • Posts: 75859
  • Thank you received: 11839
  • MODERATOR
11 years 4 months ago #7112

We're able to reproduce the problem on our end. We didn't had the time today to look at solving it but we'll look at it tomorrow.

Please Log in or Create an account to join the conversation.

  • Posts: 75859
  • Thank you received: 11839
  • MODERATOR
11 years 4 months ago #7222

Hi,

Please try to change the code:

if($class->update($coupon,$qty,0,'coupon')){
				$this->cart_update = true;
				return false;
			}
to
if($class->update($coupon,$qty,0,'coupon')){
				if(strpos($this->checkout_workflow,'shipping')!==false){
					$this->before_shipping(true);
				}
				$this->initCart(true);
				$this->cart_update = true;
				return false;
			}
in the file components/com_hikashop/controllers/checkout.php
That should solve the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 242
  • Thank you received: 0
11 years 4 months ago #7354

Hi,

My problem sounds similar but not exactly the same.

I added a coupon view to the checkout workflow, that was working OK previously. The new workflow is:

login,address,shipping_cart,payment_coupon_cart_fields_status_confirm,end

I currently don't have any Discounts published. If someone tries to add a coupon code, there is an Invalid Code error and the Shipping amount is removed from the cart completely. Clicking NEXT produces a Please Supply Shipping Information error and reverts to the Login step of the workflow. If I go to the Shipping step, there is a Shipping Zone selected and the amount is back in the cart. This same error results even if a valid Coupon code is used. i.e. Shipping is removed from the cart.

I did change the checkout.php file as instructed above, but it did not fix this problem.

Regards,
Ed

Please Log in or Create an account to join the conversation.

  • Posts: 242
  • Thank you received: 0
11 years 4 months ago #7360

Correction to my last post.

If a valid coupon code is entered, it works OK now. Maybe a cache problem before. Using an invalid coupon code still produces the behaviour described.

Ed

Please Log in or Create an account to join the conversation.

  • Posts: 75859
  • Thank you received: 11839
  • MODERATOR
11 years 4 months ago #7361

We'll look at that.

Please Log in or Create an account to join the conversation.

  • Posts: 75859
  • Thank you received: 11839
  • MODERATOR
11 years 4 months ago #7451

Hi,

The new version is out. That should fix that problem.

Please Log in or Create an account to join the conversation.

  • Posts: 242
  • Thank you received: 0
11 years 4 months ago #7768

Nicolas,

Shipping is no longer removed from the cart when an invalid coupon code is entered. Thanks for fixing that.

I noticed that in the cart, the coupon amount is shown as a negative number, which it should be, but in the email sent to the customer, it's shown as a positive number. The math is correct, but that might be confusing to some customers.

Regards,
Ed

Please Log in or Create an account to join the conversation.

  • Posts: 75859
  • Thank you received: 11839
  • MODERATOR
11 years 4 months ago #7773

You're right. We'll change that.

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum