Re: Currency update no longer working

  • Posts: 86
  • Thank you received: 0
  • Hikashop Essential
8 years 3 months ago #15472

Hi,

Recently our currency update stopped working. We are getting an error now: No data in the currencies rate feed of the European Central Bank.

Any idea what is goin wrong?

Gert.
Running 1.4.9

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
8 years 3 months ago #15484

Hi,

The service has changed its location few days ago. It was located on :
ec.europa.eu/taxation_customs/vies/servi...checkVatService.wsdl
and it is now located on:
ec.europa.eu/taxation_customs/vies/checkVatService.wsdl
Thus, you need to do that change in the file
administrator/components/com_hikashop/helpers/vat.php
We're gonna do a new release of HikaShop with that change soon.

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 0
  • Hikashop Essential
8 years 3 months ago #15523

Hi Nicolas,

Thanks for the prompt response.

The vat.php file already contained the right information. I'm stuck with currency update not with vat check.

Could it be you misread my problem?

Gert.

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
8 years 3 months ago #15524

Hi,

Indeed, I misread your problem.

The URL of the rates feed is www.ecb.europa.eu/stats/eurofxref/eurofxref-daily.xml and it is still working. I just tried on our demo website to update the rates and it is working fine.
Would you have something blocking your website from accessing the feed ?

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 0
  • Hikashop Essential
8 years 3 months ago #15555

Hi Nicholas,

I'm checking with the hosting company now. Will let you know the result.

Gert.

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 0
  • Hikashop Essential
8 years 3 months ago #15589

Hi Nicholas,

Can you tell me from what php module the link is called. My hosting provider wants to investigate.

Gert.

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
8 years 3 months ago #15599

The currency rates update process is handled in the file plugins/hikashop/rates.php

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 0
  • Hikashop Essential
8 years 3 months ago #15843

Hi Nicholas,

I'm stuck here. It's not working and I've been in touch with the hosting company over the past few days. They say nothing is blocking the connection.

What I am to do?

Gert.

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
8 years 3 months ago #15845

Could you give us an FTP access to your website as well as a back end access so that we can investigate the problem ?

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 0
  • Hikashop Essential
8 years 3 months ago #15847

send through your contact us page.

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
8 years 3 months ago #15852

The problem is that your hosting provider changed your php settings. The allow_url_fopen setting is turned off on your website which means that the file, fopen and file_get_contents functions cannot access external files but only files on your server. If it was working before it must be because that option was turned off.

We implemented an improvement on the rates feed updater so that it uses cURL if available and that this option is turned off, in order to bypass the problem. It will probably be useful to other users with the same restriction on their server. It's now working.

Please Log in or Create an account to join the conversation.

  • Posts: 86
  • Thank you received: 0
  • Hikashop Essential
8 years 3 months ago #15855

Hi Nicholas,

Once more you're wonderful.

Thanks very much! Beer still waiting for you in Bangkok :)

Gert.

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
4 months 3 weeks ago #305289

Hi Guys & Girls,

I have the same problem as this guy. How do I fix this?

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
4 months 2 weeks ago #305305

Hi,

As I said 7 years ago, the fix we gave was included in HikaShop and it is still in HikaShop.
So even though you might have the same error message, the cause is probably different.
Please provide more information on the situation:
- what exact error message do you have ?
- can you check how is configured the allow_url_fopen setting in your php.ini (you might need to contact your hosting support for that) ?
- which version of HikaShop are you using ?

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
4 months 2 weeks ago #305576

Hi Nicolas,

The error is:
No data in the currencies rate feed of the European Central Bank

allow_url_fopen = on

HikaShop 4.0.3

Please assist. Thank you.


Kind regards,

Clarence

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
4 months 1 week ago #305602

Hi,

Please check with your hosting support that cURL is activated on your hosting for your php. Then, it should work properly.

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
4 months 1 week ago #305619

Hi Nicolas,

cURL is already working. Still have the same problem.

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
4 months 1 week ago #305630

Hi,

Then I don't know what it could be.
Please provide a backend access as well as a FTP access and a link to this thread via our contact form and we can have a look at the situation:
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 49
  • Thank you received: 0
  • Hikaserial Subscription Hikashop Business
4 months 1 week ago #305642

Done.

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
4 months 1 week ago #305668

Hi,

We got the accesses and did some debugging. From that, we concluded that there is something blocking outgoing connections on your server. It's probably some security system of your hosting.
It not only blocks the connection to the European Central Bank feed, but even if we change the feed to the Yahoo finance feed (there is a setting in the plugin for that), it also returns no data back.

So the fact that you have the issue for two different feed, and that these feed work fine for me (if I test on my local website for example, both feed refresh the rates properly) and other users, indicates that something is blocking outgoing connections.
I'm afraid you'll have to check with your hosting support so that they can investigate and tell you what can be done.

You can tell them that the code:

<?php echo file('https://www.ecb.europa.eu/stats/eurofxref/eurofxref-daily.xml');
should display the XML feed from the European Central Bank but on your hosting when you do that it doesn't work.
For example, I've created a file test.php with that code at the root of your website. So you can go to yourwebsite.com/test.php and you should see the XML feed.

Please Log in or Create an account to join the conversation.

Time to create page: 0.094 seconds
Powered by Kunena Forum