Show cart module only when it has something in

  • Posts: 16
  • Thank you received: 1
4 years 9 months ago #97324

I switch "Use AJAX when possible" Yes to No and it now works fine. Thanks for you help.

Please Log in or Create an account to join the conversation.

  • Posts: 147
  • Thank you received: 6
3 years 5 months ago #166851

Hi,
Has the option to hide the empty cart if there is no product?

I noticed that in this post was said it would be added on the next version and that was a couple of years ago.
So it might have happened already but I cant figure out.

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 60490
  • Thank you received: 8527
  • MODERATOR
3 years 5 months ago #166864

Hi,

Yes. You can use a translation override in order to remove the default text in the cart when it is empty:
hikashop.com/download/languages.html#modify
Then, Joomla should not display the module if its content is empty.

Please Log in or Create an account to join the conversation.

  • Posts: 512
  • Thank you received: 3
  • Hikashop Business
1 year 2 months ago #253637

Old post but I m curious!
Have you managed to hide the cart if the cart is empty? I did erase translation from language file and in the module but the module is there. Only the text I erased is missing. What I m missing here?

Please Log in or Create an account to join the conversation.

  • Posts: 1521
  • Thank you received: 217
  • MODERATOR
1 year 2 months ago #253679

Hello,

You have to configure an new option in your Cart Module Configuration :
- Go to Extensions => Modules
- Use the input search to find required module with "Cart"



- Click on "HikaShop Cart Module" to edit it.
- Go on HikaShop options tab
- Then reproduce this configuration for Hide if empty option to Hide



Regards

Attachments:
Last Edit: 1 year 2 months ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 2
  • Hikashop Business
2 months 4 days ago #282366

It still shows module, even if its empty.
Latest Joomla and Hikashop.

Please Log in or Create an account to join the conversation.

  • Posts: 60490
  • Thank you received: 8527
  • MODERATOR
2 months 3 days ago #282367

Hi,

It's probably a problem with how your template is rendering the modules:
www.hikashop.com/forum/content-creation/...if-empty.html#274262

The following user(s) said Thank You: arnask

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 2
  • Hikashop Business
2 months 3 days ago #282396

Thanks nicolas, yes you are right.
Just for others using Yootheme templates: Go to Joomla backend >> Extensions >> Templates >> Open your template (edit) >> Options >> Modules find your module and set Style to Blank.
More info: yootheme.com/support/question/62620

The following user(s) said Thank You: Philip

Please Log in or Create an account to join the conversation.

Time to create page: 0.211 seconds
Powered by Kunena Forum