Could not start mail function

  • Posts: 74
  • Thank you received: 1
  • Hikashop Multisite
3 weeks 1 day ago #313386

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.13
-- PHP version -- : 7.4
-- Browser(s) name and version -- : all
-- Error-message(debug-mod must be tuned on) -- : Could not start mail function

Good afternoon

Hikashop has stopped sending mails since I have switched sending mails via PHP to SMTP (Joomla global settings)

Test mails from Joomla via SMTP work fine, but Hikashop fails to coöperate


Is there a Hikashop setting which I have to adjust (and missed)

Or could there be another reason?

help is very, very appreciated!

Dick

Please Log in or Create an account to join the conversation.

  • Posts: 67676
  • Thank you received: 10046
  • MODERATOR
3 weeks 1 day ago #313389

Hi,

Do you see the emails in the Customers>Emails menu ?
If so, then HikaShop is sending the emails to the email server but the email server can't send them.
In that case, you should contact your hosting support or server administrator so that they can check the log of the email server where the error will be logged. That will allow you to know what's going on.
In HikaShop you have some email settings in the Main tab of the HikaShop configuration. You might need to adapt them based on the recommendation of your hosting.

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 1
  • Hikashop Multisite
3 weeks 16 hours ago #313419

Yes Nicolas,

The mails are there

I was just wondering wether if I had to adjust some setting in Hika Configuration.
The hosting server does not send mails thru php but forces me to use SMTP
test mails from Joomla Global settings yhru SMTP work alright... but Hika mails are not send.

So I wonder if my problem is Hika, Joomla or server

greetz

Dick

Last edit: 3 weeks 15 hours ago by Formidog.

Please Log in or Create an account to join the conversation.

  • Posts: 67676
  • Thank you received: 10046
  • MODERATOR
2 weeks 5 days ago #313437

Hi,

Well, there is no particular thing to change for SMTP in HikaShop.
However, since you're using another method to send the emails, it might have other requirements.
For example, if you include a PDF invoice in the emails, maybe the SMTP server doesn't like that.
Or maybe the enconding format of the emails needs to be changed. It's hard to say without looking at the error in the log of the email server. That's why contact the hosting support is what I recommend. You already know that HikaShop do send the emails to the email server, so it means that the email server doesn't send them for some reason and the reason will be in the log of the email server.

Please Log in or Create an account to join the conversation.

Time to create page: 0.055 seconds
Powered by Kunena Forum