Translation products

  • Posts: 65
  • Thank you received: 2
  • Hikashop Business
7 months 5 days ago #356568

-- url of the page with the problem -- : www.ericspeanuts.com
-- HikaShop version -- : 5.0.0
-- Joomla version -- : 4.4.0
-- PHP version -- : 8
-- Browser(s) name and version -- : chrome

Hello,

I set up my website in multiple languages. I use the languages provided by Joomla. I filled out the translations on the product page. However, the product description does not shift to the appropriate translation when I change from one language to another. It stays with the default language, which is French.

The rest of the websites work well.

Am I doing something wrong and forgetting to activate something?

I appreciate any help you can provide.

Eric

Please Log in or Create an account to join the conversation.

  • Posts: 81852
  • Thank you received: 13139
  • MODERATOR
7 months 4 days ago #356577

Hi,

Are you using Falang ?
Could you provide screenshots of the settings of a product in your backend, and of its translation popups, and the corresponding link on the frontend so that we can check the situation ?

Please Log in or Create an account to join the conversation.

  • Posts: 65
  • Thank you received: 2
  • Hikashop Business
7 months 4 days ago #356592

Please find print screens of the back end and a link to the English translation, but the product's description remains in French. www.ericspeanuts.com/en/shop-en/product/...-butter-crunchy-270g


Thank you and best regards

Eric

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 65
  • Thank you received: 2
  • Hikashop Business
7 months 4 days ago #356593

I am not using falang

Please Log in or Create an account to join the conversation.

  • Posts: 81852
  • Thank you received: 13139
  • MODERATOR
7 months 3 days ago #356595

Hi,

Thanks.
Please activate temporarily the "debug language" setting of the Joomla configuration and check at the bottom of the page with the issue.
It point point at at some problems with the translation override file, preventing Joomla from processing it on the frontend to access the translations.

Please Log in or Create an account to join the conversation.

  • Posts: 65
  • Thank you received: 2
  • Hikashop Business
7 months 3 days ago #356598

Ok I just did. I could not see anything special. There was no error message.

Attachments:
Last edit: 7 months 3 days ago by epware.

Please Log in or Create an account to join the conversation.

  • Posts: 81852
  • Thank you received: 13139
  • MODERATOR
7 months 3 days ago #356605

Hi,

Your screenshot says that Joomla doesn't find the translations.
So I'm thinking HikaShop might have found you still have the Falang tables in the database and thus is saving the translations in there, but they are not used because Falang has been uninstalled.
Could you check if you have the falang tables in your database via your PHPMyAdmin ?
If so, rename them, and redo the translations via the interface in the backend and it should then work.

Please Log in or Create an account to join the conversation.

  • Posts: 65
  • Thank you received: 2
  • Hikashop Business
7 months 2 days ago #356625

Ok I will check all that and revert. Thank you for the help

Please Log in or Create an account to join the conversation.

  • Posts: 65
  • Thank you received: 2
  • Hikashop Business
7 months 1 day ago #356643

Ok it works. Pb solved. Thank you

Please Log in or Create an account to join the conversation.

Time to create page: 0.078 seconds
Powered by Kunena Forum