Skip to main content

Access forbidden Error

More
12 years 6 months ago #148617 by eabuel
-- url of the page with the problem -- : southernempress.com/administrator
-- HikaShopBusiness -- : 2.3.0
-- Joomla version -- : 3.2
-- PHP version -- : 5.4
-- Browser(s) name and version -- : Chrome, Firefox
-- Error-message(debug-mod must be tuned on) -- : Error_message

I'm trying to export my list of serials into a CSV file for a company that is going to be selling them for me. When I go into the pack, I see the first 20 serials, but when I go to page 2 I get Error Access forbidden.

Thanks for your help.
Everett Buel

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #148619 by Jerome
Replied by Jerome on topic Access forbidden Error
Hi,

Can you please indicate your HikaSerial version number ?
I suppose it's a problem related to the Joomla 3 access system.
Could you give me the page you where when you got the 500 page ? "ctrl=serial&task=listing" ?
Thanks to this information I should be able to reproduce it in my local Joomla 3 website.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #148622 by eabuel
Replied by eabuel on topic Access forbidden Error
HikaSerial: 1.8.1 the Latest

southernempress.com/administrator/index....kaserial&ctrl=serial

I have been removing some of the serials manually so there isn't 500 now, but plenty to reproduce.

thanks for your help again Jerome

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago - 12 years 6 months ago #148624 by Jerome
Replied by Jerome on topic Access forbidden Error
Hi,

Can you please try to replace in the file "administrator/components/com_hikaserial/views/serial/view.html.php" the content
Code:
$filterType = $app->getUserStateFromRequest($this->paramBase.'.filter_type', 'filter_type', 0, 'int');
By:
Code:
$task = JRequest::getVar('task', ''); if(empty($task)) $task = 'listing'; $this->assignRef('task', $task); $filterType = $app->getUserStateFromRequest($this->paramBase.'.filter_type', 'filter_type', 0, 'int');
It should initialized correctly the task for Joomla 3 and work correctly when changing the page.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Last edit: 12 years 6 months ago by Jerome.

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #151267 by eabuel
Replied by eabuel on topic Access forbidden Error
Hello Jerome,

Sorry for the delay on this, it got pushed to the bottom of my list.

Your fix didn't work. I would be glad to set you up with ftp access if you like.

Cheers for now,

Everett

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #151269 by Jerome
Replied by Jerome on topic Access forbidden Error
Hi,

You can send me some backend access and ftp access by private message.

Kind regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #169205 by nowherenowhere
Hi Guys,

I have a problem like this on J 3.3.3 with Hikaserial 1.8.3 - I have a few packs using the plugin attach serial.I can only see the first 20, when I try to go to the next page or use the >> I get the error:

Error
Access forbidden

Please help me, I've tired applying the above code... to no effect

Believe in Better

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #169209 by Jerome
Replied by Jerome on topic Access forbidden Error
Hi,

Thanks for the report.
Please edit the file "administrator/components/com_hikaserial/views/pack/view.html.php" and replace
Code:
$filterType = $app->getUserStateFromRequest($this->paramBase.".filter_type", 'filter_type', 0, 'int');
By
Code:
$filterType = $app->getUserStateFromRequest($this->paramBase.".filter_type", 'filter_type', 0, 'int'); $task = JRequest::getVar('task', ''); if(empty($task)) $task = 'listing'; $this->assignRef('task', $task);
It will fix the problem of pagination in the pack listing.
(the patch will be include in the next HikaSerial release).

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #169213 by nowherenowhere
Hiya Jerome... nope error still persists..

Believe in Better

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #169219 by Jerome
Replied by Jerome on topic Access forbidden Error
Hi,

I got the error in my Joomla 3.3 test website while browsing the packs in the backend, but with the patch the problem is solved.
In the plugin "attach serial", the selection of the packs is made using the namebox system, there is no pagination into it (so not possibility to change the page).

So, I don't know of which problem you're talking about.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.266 seconds
Powered by Kunena Forum