Can't link the product and pack.

  • Posts: 61
  • Thank you received: 0
6 years 7 months ago #217507

-- HikaShop version -- : 2.6.0
-- HikaSerial version -- : 1.10.0
-- Joomla version -- : 3.4.4

I don't know what actually happened, but after updating hikaserial to 1.10 I can't link the product and pack anymore.
In product I press Add button in SERIALS section -> selecting pack I need and right after pressing "Add packs" button it redirecting me back to the products list in Hikashop without any saving. So it doesn't work now, but on 1.9 everything was fine.

upd. Just restored backup with Hikashop previouse and and Hikaserial 1.9 - everything is working. Hikashop 2.6.0 + Hikaserial 1.9 - everything is working too. As soon as I update Hikashop to 1.10.0, and "Add packs" button appears, I can't link products and serial pacj anymore.
Error screenshot in console is attached.

Attachments:
Last edit: 6 years 7 months ago by DimLVL.

Please Log in or Create an account to join the conversation.

  • Posts: 25255
  • Thank you received: 3908
  • MODERATOR
6 years 7 months ago #217511

Hi,

The function "oNamebox.prototype.get" is right defined in the "otree.js" file in HikaShop 2.6.0.
And I can't reproduce the issue in my local website or in the HikaShop demo website.
Please be sure that your browser does not have in cache an old version of that file (you can do a "ctrl+f5" to force a full reload).

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 61
  • Thank you received: 0
6 years 7 months ago #217524

Hello. That's not the cashe problem. I've tried different browsers, I've used ctrl+f5 as well. I have uninstalled Hikaserial and installed 1.10 withour upgrading. Unfortunately It's still not not working. I don't have any idea, how to make it working.
Also can I ask you to give me a link for Hikaserial 1.9, to make it work at least on previos version, until I will find the reason of the problem?
Found that it's not necessary to add any pack. I can just click Add packs button and it will rederect me to the whole products list. It seems button is with that button. Could it be any libraries conflict?

Last edit: 6 years 7 months ago by DimLVL.

Please Log in or Create an account to join the conversation.

  • Posts: 25255
  • Thank you received: 3908
  • MODERATOR
6 years 7 months ago #217530

Hi,

It is not related to HikaSerial but to HikaShop ; it is HikaShop which provide the library :

The function "oNamebox.prototype.get" is right defined in the "otree.js" file in HikaShop 2.6.0.

.
Because we can't reproduce the issue locally or in the demo website ; it will be difficult for us to create a fix.
So if you can provide us a temporally backend access to your website so we can take a look at the issue ; it will help a lot.
You can use the "contact us" form to send us such private information (with a link to that forum thread so the support team will assign me that ticket).

If you want access to HikaShop 1.9 package ; please also use the "contact us" form so we can send it to you.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 61
  • Thank you received: 0
6 years 7 months ago #217568

The conflict is with HikaMarket 1.6.5 provided by the website developer. I've check that on clean joomla too. Unfortunately it seems that his license is expired and he can't provide 1.6.6 upgrade. So can you tell me please, will you make any fix for that bug or we have to buy own licence for us?

Please Log in or Create an account to join the conversation.

  • Posts: 25255
  • Thank you received: 3908
  • MODERATOR
6 years 7 months ago #217577

Hi,

I didn't know that HikaMarket was installed in the website.
The easier will be to update the "otree.js" file ; you just have to copy the one in the "/media/com_hikashop/js/" into "/media/com_hikamarket/js/" one and it will fix it.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
The following user(s) said Thank You: DimLVL

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.065 seconds
Powered by Kunena Forum