Translation problem in mail

  • Posts: 151
  • Thank you received: 9
11 years 7 months ago #70274

Hi,

In the confirmation e-mail that is sent to the customer, the serial no. column headers "Serial Data" and "Attached to product" won't translate.

I have filled the override language file in HikaSerial and even the original language file.

Help-> Update/About says: You have the latest stable version : 1.4.0.

What can be wrong?

Maurice

Please Log in or Create an account to join the conversation.

  • Posts: 26034
  • Thank you received: 4006
  • MODERATOR
11 years 7 months ago #70291

Hi,

The content of this email in store in two views called "show_email_notification".
One for the backend and one for the front-end (it depends "who" will validate the order).

Did you override one of these views ?

HikaSerial have translations for SERIAL_DATA and ATTACHED_TO_PRODUCT since version 1.0

ATTACHED_TO_PRODUCT="Attached to product"
SERIAL_DATA="Serial Data"
If your language file have an error it could be possible that HikaSerial translation wouldn't be loaded by Joomla.
The override file is used by HikaSerial and HikaShop so, evenif HikaSerial does not load properly his language file, HikaShop could use the override file.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 151
  • Thank you received: 9
11 years 6 months ago #72692

Hi Jerome,

Both files are not overridden. If I do that and make some customization to the override file's nothing happens.
If I then, remove the override file, again nothing changes.

I checked ALL the language files and their overrides, I cannot find any errors. All lines are properly openened and closes with double quotes and there are no double quotes within those strings. There are no escaped double quotes either.

It's driving me crazy, since I cannot find the error... :S

Maurice

Please Log in or Create an account to join the conversation.

  • Posts: 26034
  • Thank you received: 4006
  • MODERATOR
11 years 6 months ago #72713

Hi Maurice,

When you override a view, you have to select the view for the right template. Maybe you modified a view for another template and that's why you don't see any modification.

Can you send me, by private message, an access to your website ?
I will take a look and try to fix your problem.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 151
  • Thank you received: 9
11 years 6 months ago #72728

Hi Jerome,

I did modify the views for the correct template...

I've sent you a PM.

Thank you in advance!

Maurice

Please Log in or Create an account to join the conversation.

  • Posts: 151
  • Thank you received: 9
11 years 6 months ago #72733

Another issue, that may have to do with this.

When someone has a 100% discount coupon (via AwoCoupon) the confirmation e-mail is not sent.

So I change the order status manaually back to "created" with NO notification to the customer.
Then I change the status back to "confirmed" and I select Notify Customer.

Then the email body should open, to review it

Sometimes the HTML e-mail body does not open and sometimes it does.
This morning the e-mail body opened for about 40 orders (with the 100% discount coupon)
and now that e-mail body does not open anymore.

I've seen before that sometimes the e-mail HTML body did not open.

This all happend with the "confirmation" e-mail.

And if the e-mail body does open, I see the two Hikaserial textstrings that are in English that
won't translate.

Could it be an error in the e-mail template for the confirmation mail that causes these problems?

Maurice

Last edit: 11 years 6 months ago by Maurice.

Please Log in or Create an account to join the conversation.

  • Posts: 26034
  • Thank you received: 4006
  • MODERATOR
11 years 6 months ago #72739

Hi,

I was thinking that text won't translate at all, but in fact, text are translate in English.

The problem is linked to multiple languages : The default language is "English" and so, HikaSerial english translations are used.
When an order is sent by HikaShop, it dynamically change the language and reload the HikaShop translation file.
Since Joomla 1.6, we can't reload the override file twice (in the backend), that's why you can't use them in the backend. We are looking for a solution for this point.

I have added a fix in HikaSerial in order to reload the language file depending the order customer, like HikaShop does.
I will make some tests and you would probably update the HikaSerial 1.4.0 package (or send you the modified file by email).
I can't publish HikaSerial 1.5.0 for the moment because it requires HikaShop 2.0.0

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 151
  • Thank you received: 9
11 years 6 months ago #72767

Hey Jerome,

Great! I am so happy that you found the cause of the problem. It drove me nuts.

Indeed, when I change the backend language to "Dutch", the strings are translated correctly.

HikaShop 2.0.0? I have 1.6.0. and in the backend it says: "You have the latest stable version : 1.6.0".

The not opening of the HTML body issue was a web browser related issue. I used Firefox when I had that problem. When I switch to Chrome, te issue is not there. So it has definitely nothing to do with the translation issue, nor do I think the e-mail template is corrupt. All works fine, except that the confirmation e-mails are not sent when customers use a 100% discount coupon. I will discuss this in the HikaSHop forum.


So please let me know when I can download the new HikaSerial version.

Thank you for your very fast response and help!!

Maurice

Last edit: 11 years 6 months ago by Maurice.

Please Log in or Create an account to join the conversation.

  • Posts: 26034
  • Thank you received: 4006
  • MODERATOR
11 years 6 months ago #73228

Hi,

HikaShop 2.0 is actually in beta and the release would be very soon (before the end of the week).
HikaSerial 1.5 would be published in the same time.

New version would provide a full support of Joomla 3.0, PHP 5.4 compatibility, a lot of improvements and some new features.
I am finishing some things for HikaSerial 1.5 and unique download features. Hope it would be appreciated :)

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.069 seconds
Powered by Kunena Forum