Errors when trying to import

  • Posts: 12
  • Thank you received: 0
10 years 10 months ago #25913

Hello.

When trying to import images into my shopping cart (first time trying to use image generate), I get the following 2 errors:

- JFolder::create: Could not create directory
- The folder /hikashop/ is not writable


See attached screenshot.

I am importing from a folder that is on my live server
I am importing into a folder that has all the permission required.

I managed to work fine on my home PC but as soon as I try on the live hosting server I get these errors.

Regards
Deon

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76147
  • Thank you received: 11918
  • MODERATOR
10 years 10 months ago #25926

Hi,

You need to set the full path in the "folder path" option.
Do you really have a folder /hikaimport on your server ?
Usually, the root of the server is not available to webmasters and it's more something like /home/website.com/public_html.

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
10 years 10 months ago #25966

I tried using folder /public_html/hikaimport but it gave the same errors.
And yes, I created the 'hikaimport' folder in my root and FTP'
s 450 photto to it. This is where I upload all my images to (takes forveerr to uoload 450 impages through FTP) prior to trying to import it into the shopping cart.

I also tried /home/public_html/hikaimport but got "0 products found : 0 new products imported, 0 invalid product code, 0 already existing products"

Can I import from my C: drive on my computer instead of having to load all images to the server and then importing from there?
I tried c:\hikaimport in the folder but I get message "0 products found : 0 new products imported, 0 invalid product code, 0 already existing products" probably because it cannot see my C: drive.

Deon

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
10 years 10 months ago #25967

I also tried "/home/wendimu1/public_html/hikaimport/" as that looked like the full path in my cPanel File Manager and it also gave "0 in, 0 out" message.

Deon

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
10 years 10 months ago #25968

Ok, got it to work.. when I moved the folder I somehow lost the images. Added images back and import works fine.

My next question: when a visitor comes to the shopping cart, I only want to show them categories first. Then if they click on a category, I want to show them all products in category. Right now when a user goes to shopping cart, it displays the category on the top line and then fills up the page with products in that category on the same page. How do I get rid of the products displaying in that initial category view?

Deon

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76147
  • Thank you received: 11918
  • MODERATOR
10 years 10 months ago #25973

It's probably because you set the option "sub element filter" to "all sub elements" instead of "direct sub elements" in the hikashop options of the associated module of your menu.

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum