Taxes and Checkout Help

  • Posts: 61
  • Thank you received: 2
8 years 9 months ago #115158

Hi,

I am using Hikashop Business for our current site: beckwithsafes.com/index.php.

We set it up so there are only sales taxes applied to Florida residents. It works great and applies the taxes when the person fills in their address. The problem is that if the person doesn't complete their checkout the system saves their address information in the cart area. Which is fine. However, if the person continues shopping it now displays the prices with taxes in the product listing area but when they click to view the product info page it shows it without taxes. This can be quite confusing.

I have set the Configuration > Main > Taxes to display show taxed prices "no tax" and also went into Display > Content Menus > Product listings and also set it to show taxed prices "no tax" but this doesn't solve the problem. I would like it to never display taxes except on the checkout page after they fill out their address. Please advise.

The other issue I am encountering is when checking out if I leave the page where it haves me confirm my billing/address info to continue shopping and then return to the checkout page to edit my address info, once I hit okay in the pop-up box it takes me to the "Product Category" page instead of updating my billing info. I am not sure how to fix this. Please advise on this as well.

The current site is set to debug mode. Thanks so much for your time.

Please Log in or Create an account to join the conversation.

  • Posts: 75517
  • Thank you received: 11750
  • MODERATOR
8 years 9 months ago #115165

Hi,

1. Go in the menu Display->Content modules, edit all your products listings modules and make sure that the show taxed prices option is also disabled.

2. Can you download again the 2.2 version on our website and install it on yours and try again ? We've published a new build of the 2.2 version which might help.

Please Log in or Create an account to join the conversation.

  • Posts: 61
  • Thank you received: 2
8 years 9 months ago #115314

Hi Nicolas,

We don't have any content modules enabled. They are all unpublished.

I also downloaed the new 2.2 build and it didn't solve the issues. What are the next steps we should take?

I also noticed when going back to the checkout after leaving that if I go to edit the shipping address it also sends me back to the Product category page. Then when I go back to the cart it now shows 2 billing addresses and 2 shipping addresses. If I try to delete any of them it just sends me back to the Product category page again.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12953
  • Thank you received: 1774
8 years 9 months ago #115442

Hi,

nicolas wrote: 1. Go in the menu Display->Content modules, edit all your products listings modules and make sure that the show taxed prices option is also disabled.


I think that you'll be able to go to this module by going to your content menu configuration screen and then using the link of the Associated modules, then you'll be redirected to the module.

Please Log in or Create an account to join the conversation.

  • Posts: 61
  • Thank you received: 2
8 years 9 months ago #115541

I went to that area and it brought up the same modules. None of them are enabled but I went ahead and set them all to not show taxes. That fixed it, so thanks! I guess even though they aren't enabled it still effects that page.

I am still having the other issues mentioned above. Please let me know if I need to send the site's login or FTP info so you can look into it further. I would appreciate if it could be fixed. The two issues left from above are:


"The other issue I am encountering is when checking out if I leave the page where it haves me confirm my billing/address info to continue shopping and then return to the checkout page to edit my address info, once I hit okay in the pop-up box it takes me to the "Product Category" page instead of updating my billing info. I am not sure how to fix this. Please advise on this as well."[/b]

and

"I also noticed when going back to the checkout after leaving that if I go to edit the shipping address it also sends me back to the Product category page. Then when I go back to the cart it now shows 2 billing addresses and 2 shipping addresses. If I try to delete any of them it just sends me back to the Product category page again."

Thanks for your time and help.

Last edit: 8 years 9 months ago by bludove30. Reason: Added more details

Please Log in or Create an account to join the conversation.

  • Posts: 61
  • Thank you received: 2
8 years 9 months ago #115607

If you could please answer these two questions as soon as possible it would be very appreciated. We have a client waiting on this to get finished out.

Thank you.

Please Log in or Create an account to join the conversation.

  • Posts: 75517
  • Thank you received: 11750
  • MODERATOR
8 years 9 months ago #115867

These questions were answered by email.
Basically, it's a bug coming from the Joomla 3 SEF system which happened following an optimization we did on checkout SEF URLs in HikaShop.
We've published a new build of the 2.2 to circumvent the problem.

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum