Cron is gone!no emails! it was working fine before

  • Posts: 156
  • Thank you received: 0
11 years 1 month ago #19034

it says the next time it will run is in 2009? and when i click the link it's a 404 not found.. please advice..

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 1 month ago #19036

You don't have the index2.php file. Did you deleted it ?
You can edit the cron and change the index2.php in the url to index.php and it will work.

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 0
11 years 1 month ago #19040

i edited it, and it updated the date but the url stayed the same. and no i didn't delete index2.php, idk why it wouldn't be there.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 1 month ago #19041

It should work now.

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 0
11 years 1 month ago #19047

i would like to trigger it from my end on my server. what is the line that i need to enter into command field in the section of cron jobs?

also would it send the email that were not sent before? or is there somewhere to resend the past ones? cause i am not getting any by triggering the cron now.

on the past screenshot i was trying to point out that the corn url still had index2.php even tho i edited the cron job.

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 1 month ago #19049

If you want to manually trigger the cron via the command line, you can do like that: www.hikashop.com/support/documentation/5...ron-task.html#server

What emails are you talking about ? The cron notification emails ? I don't recall that other emails are being sent with the cron task in HikaShop ? If you're talking about the cron notification emails, you need to wait as it can take up to 15 minutes before getting it.

Yes I understood. It's just a display issue so don't worry of the index2.php there.

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 0
11 years 1 month ago #19064

i waited the suggested time of 15 minutes , i entered a new order and i not getting any emails to the admin or client , i also added the cron job to my server for every 5 minutes. no email has been received. i even sent a email by changing the order status and no email has been received.

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 1 month ago #19066

Emails in HikaShop are NOT sent using the cron task. They are sent immediately.
If your emails are not delivered, it's because of either your joomla email configuration or your email server.

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 0
11 years 1 month ago #19067

if it helps to know, i just moved the site yesterday to a new server, i used akkeba back to move it with kickstart.

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 0
11 years 1 month ago #19069

like i said it was working fine before why would it stop working out of nowhere? i have it using the phpmail. check out the settings

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76113
  • Thank you received: 11909
  • MODERATOR
11 years 1 month ago #19071

Probably because your new server does not handle emails like your previous one... I'm almost sure that the registration emails of joomla do not get sent either on your website.
Maybe your new server requires you to use a SMTP connection to send the emails ? You should ask your hosting company about that problem.

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum