ACYmailing problem on last step of checkout

  • Posts: 205
  • Thank you received: 18
  • Hikashop Business
10 years 6 months ago #2646

I am using HikaShop Essentials and Acymailing Starter v1.2.2 with the Hikashop Acymailing plugin enabled and getting this error on the last step of the checkout process:

[/Warning: include_once(/home/xxxx/public_html/administrator/components/com_acymailing/classes/filter.php) [function.include-once]: failed to open stream: No such file or directory in /home/xxxx/public_html/administrator/components/com_acymailing/helpers/helper.php on line 213

Warning: include_once() [function.include]: Failed opening '/home/xxxx/public_html/administrator/components/com_acymailing/classes/filter.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxxx/public_html/administrator/components/com_acymailing/helpers/helper.php on line 213

Fatal error: Call to undefined method stdClass::trigger() in /home/xxxx/public_html/plugins/hikashop/acymailing.php on line 42



I tried disabling the Acymailing plugin but still the same error.

Any ideas?

cheers!

Last edit: 10 years 6 months ago by JIK.

Please Log in or Create an account to join the conversation.

  • Posts: 73080
  • Thank you received: 11164
  • MODERATOR
10 years 6 months ago #2647

The filters were added in acymailing 1.5.0. You should either unpublish the acymailing plugin or update acymailing.
The acymailing plugin for hikashop (not the hikashop plugin for acymailing) can be unpublished in the configuration under the tab plugins.

Also, another solution would be to just remove the code
$filterClass = acymailing::get('class.filter');
$filterClass->subid = $sub->subid;
$filterClass->trigger('hikaorder_'.$order->order_status);
form that file since anyway your version of acymailing does not handle triggers.

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 18
  • Hikashop Business
10 years 6 months ago #2660

Great! I updated Acymailing to the current version and everything works perfectly now.

Thanks!

Please Log in or Create an account to join the conversation.

Time to create page: 0.056 seconds
Powered by Kunena Forum