Hikashop Footer still showing after setting to No

  • Posts: 24
  • Thank you received: 3
  • Hikashop Business
2 weeks 5 days ago #279692

-- HikaShop version -- : 3.0.1
-- Joomla version -- : 3.8.0
-- PHP version -- : 7.0
-- Browser(s) name and version -- : Chrome 61

When the show_footer setting is set to "No", the footer still shows up.

I think it's because the hikashop_footer function is comparing the boolean to -1, when the only possible values are 1 and 0.

Please Log in or Create an account to join the conversation.

  • Posts: 11107
  • Thank you received: 1560
  • MODERATOR
2 weeks 5 days ago #279696

Hello,

I just tested it on my end and it actually worked fine, did you use the "Show footer" option via "Hikashop->System->Configuration->Display" ?

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 3
  • Hikashop Business
2 weeks 5 days ago #279734

Yes, that is the setting I used. I checked #__hikashop_config and the setting for show_footer is 0.
I also looked into the Helper class and see that the condition is

if($config->get('show_footer',true)=='-1') return '';

Just for reference, the footer appears at the bottom of the "hika-content" DIV, in the categories listing view.

Please Log in or Create an account to join the conversation.

  • Posts: 11107
  • Thank you received: 1560
  • MODERATOR
2 weeks 4 days ago #279763

Hello,

Note that you also have that line :

	if(!$config->get('show_footer',true)) return $text;

It's actually working fine on my end, so you should probably download the last Hikashop version, install it and test it again. Else using the "display:none;" CSS property will probably do the job.
www.hikashop.com/support/documentation/1...the-display.html#css

Please Log in or Create an account to join the conversation.

Time to create page: 0.071 seconds
Powered by Kunena Forum