Missing Language Strings on Search Error Page

  • Posts: 26
  • Thank you received: 0
2 months 3 weeks ago #302174

-- HikaShop version -- : 4.0.1
-- Joomla version -- : 3.9.1
-- PHP version -- : 7.2.10
-- Browser(s) name and version -- : Firefox 64.0

If there is a search error (e.g. try searching for a a term less than 3 characters), the search area strings that should say "Brands" and "Products" instead show as MANUFACTURERS_SEARCH and PRODUCTS_SEARCH. See attached screenshot.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2075
  • Thank you received: 283
  • MODERATOR
2 months 2 weeks ago #302211

Hello,

You can edit your language file in order to correct this, learn more thanks to this tutorial .

Just use the language key (MANUFACTURERS_SEARCH, PRODUCTS_SEARCH) in order to check the trad part.
Hope this will help you to corret your issue.

Regards

Last edit: 2 months 2 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 0
2 months 2 weeks ago #302243

Sorry, to be clearer, the language strings load fine if the search string has no error (i.e. search for a term greater than 3 characters). They shows as MANUFACTURERS_SEARCH and PRODUCTS_SEARCH when there is an error (i.e. search for a term less than 3 characters).

Please Log in or Create an account to join the conversation.

  • Posts: 2075
  • Thank you received: 283
  • MODERATOR
2 months 2 weeks ago #302261

Hello,

Then it's not the same discussion, can youi provide these elements :
- An Url link to see and process some tests by ourselve
- A step by step procedure to reproduce your issue
- Your Filter configuration screenshot
- Any details that can help us to quick get the root issue

Awaiting news from you
Regards

Last edit: 2 months 2 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 0
2 months 2 weeks ago #302291

Sure thing. I am able to reproduce this on the HikaShop demo site:

  1. Go to the Joomla Search URL: demo.hikashop.com/index.php/en/?option=com_search&view=search . The search area ("Search Only") names are initially correct here: Brands, Products, Vendors.
  2. In the field up top where it says "Search Keyword", type "ad".
  3. Hit Return or click the magnifying class button. The search area names now show: MANUFACTURERS_SEARCH, PRODUCTS_SEARCH, HIKA_VENDORS.

Please note this is using the core Joomla Search, not the HikaShop Filter. As mentioned, if the search term is 3+ characters (i.e. "headphone"), then this problem does not appear.

Please Log in or Create an account to join the conversation.

  • Posts: 65163
  • Thank you received: 9467
  • MODERATOR
2 months 2 weeks ago #302325

Hi,

Please add the code:

		if(!defined('DS'))
			define('DS', DIRECTORY_SEPARATOR);
		if(!include_once(rtrim(JPATH_ADMINISTRATOR,DS).DS.'components'.DS.'com_hikashop'.DS.'helpers'.DS.'helper.php')) return array();
after the line:
function &onSearchAreas(){
in both the files plugins/search/hikashop_products/hikashop_products.php and plugins/search/hikashop_categories/hikashop_categories.php
That should fix the problem.
We'll add that patch on our end too.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 0
2 months 2 weeks ago #302363

Thanks, it works.

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum