Custom Field - Checkbox with special characters not selecte

  • Posts: 17
  • Thank you received: 0
  • Hikashop Business
3 months 3 weeks ago #306219

-- HikaShop version -- : 4.0.3
-- Joomla version -- : 3.9.5
-- PHP version -- : 7.1.25
-- Browser(s) name and version -- : all browsers
-- Error-message(debug-mod must be tuned on) -- : No error message but functional problem

Hi,

I have noticed that custom fields of a product and that have the type checbox that have a value with a special character (like ë of á ) can not be saved . If you save the product and reopen it again the selection of the value is gone.

Best regards,
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 66630
  • Thank you received: 9809
  • MODERATOR
3 months 3 weeks ago #306223

Hi,

Thank you for your feedback.
Change the line:
$v = (string)$v;
to:
$v = (string)htmlentities($v, ENT_COMPAT, 'UTF-8');
in the file administrator/components/com_hikashop/classes/field.php and that should fix the problem.
Let us know how it goes.

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 0
  • Hikashop Business
3 months 2 weeks ago #306295

Hi,

Thanks for the bugfix. It works fine!
Will it be in the next version of Hikashop or should I replace field.php again in the next update?

Regards,
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 2199
  • Thank you received: 293
  • MODERATOR
3 months 2 weeks ago #306297

Hello,

Yes, but before this we were waiting news from you before add it to our code, now we can tell you that this will be in our next release !
So, thanks for your return.

Regards

Please Log in or Create an account to join the conversation.

Time to create page: 0.058 seconds
Powered by Kunena Forum