Bug found for hikashop cart module

  • Posts: 548
  • Thank you received: 11
  • Hikamarket Multivendor Hikashop Business
1 week 5 days ago #360131

-- HikaShop version -- : 5.0.1
-- Joomla version -- : 4.4.3
-- PHP version -- : 3.7.0

For "Hikashop Cart Module > Hikashop Options > Hide if empty", the previous version can add HTML code, but the latest version cannot add code to it. After adding the code, it will automatically change the code to 0 after saving.

Please Log in or Create an account to join the conversation.

  • Posts: 81428
  • Thank you received: 13058
  • MODERATOR
1 week 5 days ago #360135

Hi,

HikaShop doesn't filter what you can and can't input in this setting.
Either Joomla is doing it, or you have a security extension or software which does it.
I have no issue adding HTML in that setting with the latest version of HikaShop on my test website.

Please Log in or Create an account to join the conversation.

  • Posts: 548
  • Thank you received: 11
  • Hikamarket Multivendor Hikashop Business
23 hours 3 minutes ago #360306

May I know how to solve this problem? Previous versions don't have this issue.

Please Log in or Create an account to join the conversation.

  • Posts: 81428
  • Thank you received: 13058
  • MODERATOR
18 hours 29 minutes ago #360310

Hi,

You said initially that you have HikaShop 5.0.1. Maybe updating HikaShop to the latest version would help since I don't have the issue with it ? If this doesn't help, then I don't know what the problem is. If it's a security component on your website or your server which is blocking this, then you need to ct on this security component.

A simpler approach would be to not use this setting. If you leave it empty, HikaShop will display instead the default empty cart message in the cart module when the cart is empty. And in that case, you can use a translation override on the CART_EMPTY translation key to set your HTML.

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum