Activation Problem

  • Posts: 2
  • Thank you received: 0
11 years 5 months ago #9965

Hi
There are 2 big problem with activation of new users.
First of all can you tell me how to show the activation message on registering.
And please try to correct it in your next version.

2nd is if a user is not activated and he/she login then it doesn't show any error and retrieve a wrong address of some other users this is a very serious bug i think.

Hikashop is an awesome service so please try to solve these 2 problems i have mentioned.

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 5 months ago #9968

Hi,

1. That is not a problem in HikaShop but in your template: www.hikashop.com/en/support/documentatio...tibility-issues.html

2. That's indeed a bug that no one reported yet. It seems that the login function of joomla does not return an error in such case which is why hikashop believes that the login was successful. You can edit the file components/com_hikashop/controllers/checkout.php and change the code:
if(JError::isError($error)){

by:
$user =& JFactory::getUser();
if(JError::isError($error) || $user->guest){

That should fix the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
11 years 5 months ago #9981

Thank you so much!!
The problem has been solved out. Keep doing the good work!!
you guys rock!!! \m/

Please Log in or Create an account to join the conversation.

Time to create page: 0.055 seconds
Powered by Kunena Forum