Issue with product listing pagination when filters are used

  • Posts: 195
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
1 month 4 weeks ago #330735

-- HikaShop version -- : 4.4.1
-- Joomla version -- : 3.9.25
-- PHP version -- : 7.4.14

On our products listing page, everything works pretty fine with the pagination.
OUR-SITE.com/products-listing

Now from the left filters first dropdoun you select a category and you get the expected result. So far so good.
Here is the first filtered page that shows correct:
OUR-SITE.com/products-listing?limitstart=0&filter__3=320

If you click number 2 of pagination you get nothing. There are products but they do not show.
Link to page 2 of the filter results:
OUR-SITE.com/products-listing?limitstart...20&filter=1&limit=21

Can you please advise?

Regards

Last edit: 1 month 3 weeks ago by liaskas.

Please Log in or Create an account to join the conversation.

  • Posts: 72763
  • Thank you received: 11096
  • MODERATOR
1 month 3 weeks ago #330840

Hi,

I'm not seeing what you describe on your links.
I don't see any filter on the left on your first link, and the third link works fine.
I suppose you must have changed something in the mean time.
If you still want our help on this issue, could you provide the means for us to see the problem ?
Could you also provide a screenshot of the settings of the filter and of the settings of the filter module ?

Please Log in or Create an account to join the conversation.

  • Posts: 195
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
1 month 3 weeks ago #330860

Thank you for your reply Nicolas
Yes we are making changes to our site, rebuilding it with the joomla default template. The pagination seems working fine with this template, so there is no need for further investigation.

Thank you anyway and forgive me for being late to reply.

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum