Hikashop pour Joomla 4

  • Posts: 93
  • Thank you received: 4
  • Hikashop Business Shipstation Updated
10 months 1 week ago #335107

Bonjour;

Juste une question. Au moment de passer à Joomla 4 , on m'indique que Hikashop est bien compatible mais pas la floppée de plugin. Cela pourrait causer des erreurs. Pouvez-vous me dire si ont peut réellement utiliser Hikashop sur Joomla 4 ?
Merci

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11829
  • MODERATOR
10 months 1 week ago #335108

Bonjour,

Oui, pas de souci. Cela fait des mois que j'utilise HikaShop avec joomla 4 (beta, RC et final) sur mon site de dev local principal.
Après, il est un peu tôt pour passer un site live sous Joomla 4.
Je vous recommande plutôt d'en faire une copie et de faire la mise à jour sur la copie pour voir les problèmes que vous rencontrez et remonter cela aux développeurs concernés, car même si cela fait 2 ans que nous avons préparé HikaShop, il est toujours possible qu'il y est des soucis que nous n'avons pas trouvés jusqu'à maintenant du fait des nombreuses fonctions et options et de leurs interactions et des interactions avec d'autres extensions.

Please Log in or Create an account to join the conversation.

  • Posts: 44
  • Thank you received: 4
  • Hikashop Business
5 months 1 week ago #338702

Bonjour,
Oui sans problème. Nous avons procédé à cette migration depuis J3 vers 4. Cela se passe sans encombre malgré les alertes rouges des différents Plug In HS.
Cdlt

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikaserial Subscription
1 month 1 week ago #341673

Bonjour,

Je viens de procéder à la migration d'un site de joomla 3 à Joomla 4 et beaucoup de plugin ne semble pas compatible, par exemple :

Call to undefined method Joomla\CMS\Application\AdministratorApplication::isAdmin()
JROOT\plugins\system\hikashopgeolocation\hikashopgeolocation.php:47

Est ce qu'une version stable de hikashop starter existe pour Joomla 4?

Merci
bien cordialement

Please Log in or Create an account to join the conversation.

  • Posts: 3642
  • Thank you received: 493
  • MODERATOR
1 month 1 week ago #341676

Bonjour,

Starter est stable psur Joomla 4, ici ce qui coince c'est le plugin Geolocation qui pour une raison ou une autre n'a pas été mis à jour.
Suivez moi étape par étape pour le rendre capable de travailler sous J4 :
1. Allez dans le dossier "hikashopgeolocation" se trouvant (si je reprends votre adresse) à JROOT\plugins\system\
2. Ouvrez le fichier hikashopgeolocation.php, et cherchez : "if(!$app->isAdmin())"
3. Remplacer "if(!$app->isAdmin())" par "if(!hikashop_isClient('administrator'))"

Normalement cela devrait résoudre votre erreur.
Cordialement

Last edit: 1 month 1 week ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 176
  • Thank you received: 8
  • Hikashop Business
1 month 1 week ago #341705

Bonjour,

J'ai rencontré la même erreur sur toutes les boutiques Hikashop que j'ai fais passé en Joomla 4.

La solution la plus simple que j'ai trouvé c'est de simplement supprimer les plugins Hikashop (nombreux) qui sont indiqués comme non compatibles.

Je lance la mise à jour en Joomla 4 puis une fois celle-ci installée, je réinstalle Hikashop et les plugins supprimés sont à nouveau ajoutés à Hikashop et, à priori, Hikashop fonctionne sans problème.

Cordialement,

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikaserial Subscription
1 month 1 week ago #341707

Merci,

Oui c'est ce que j'avais fait avant même votre réponse, mais c'était pour vous signaler que les plugins n'étaient pas nativement compatible Joomla 4 sans intervention

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11829
  • MODERATOR
1 month 1 week ago #341706

Bonjour,

Les plugins sont bien compatibles avec Joomla 4.
Le souci, c'est que les dossiers de vos plugins n'étaient pas "writable" par Joomla et donc l'installeur Joomla n'avait pas pu mettre à jour les plugins pour la compatibilité Joomla 4.
Mais normalement, aucune manipulation n'est nécessaire. Les plugins inclus dans HikaShop sont mis à jour automatiquement à chaque mise à jour d'HikaShop.

Last edit: 1 month 1 week ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikaserial Subscription
1 month 1 week ago #341721

Bonjour,

l'ensemble de mes dossiers sont ouverts en écriture, j'ai fait ma migration sur un serveur local

Please Log in or Create an account to join the conversation.

  • Posts: 75835
  • Thank you received: 11829
  • MODERATOR
1 month 1 week ago #341722

Bonjour,

Dans un précédent message vous écrivez:

Call to undefined method Joomla\CMS\Application\AdministratorApplication::isAdmin()
JROOT\plugins\system\hikashopgeolocation\hikashopgeolocation.php:47

Est ce qu'une version stable de hikashop starter existe pour Joomla 4?

Le plugin HikaShop Geolocation est un plugin inclus dans HikaShop Business. Avec HikaShop Starter, vous devriez dépublier voir désintaller ce plugin.
J'imagine que vous aviez précédamment HikaShop Business sur votre site. Puis vous êtes passé sur HikaShop Starter. Mais du coup, les plugins inclus dans HikaShop Business et non dans HikaShop Starter n'ont pas été mis à jour à partir de ce moment.
Donc le souci n'est pas que les plugins ne sont pas compatible avec Joomla 4. Ils le sont, mais seulement si vous avez une version récente de ces plugins.

Please Log in or Create an account to join the conversation.

Time to create page: 0.102 seconds
Powered by Kunena Forum