× You can talk here in German about HikaShop. Please understand that we do not speak German at HikaShop and we can't offer support in German.

Anmeldefehler im Shop

  • Posts: 3
  • Thank you received: 0
  • Hikaauction Standard Hikamarket Multivendor Hikaserial Subscription Hikashop Business Hikashop Style
3 weeks 5 days ago #328912

-- HikaShop version -- : 4.4.0
-- Joomla version -- : 3.9.24
-- PHP version -- : 7.4.
-- Browser(s) name and version -- : Microsoft Edge Version 88.0.705.56
-- Error-message(debug-mod must be tuned on) -- : Warnung: Es gibt keinen Zugriff auf die Privaten Seiten...

Hallo zusammen!

Ich habe im HIKAShop und im MARKET-Multivendor seit kurzem das Problem, obwohl man sich korrekt jeweils registrieren kann... auch die Mailings zur Konto-Freischaltung funktionieren... dass sich die Händler und USER nicht anmelden können!
Es erscheint folgende Meldung:

"Es gibt keinen Zugriff auf die Privaten Seiten"

obwohl das Konto korrekt im System gespeichert wurde.

Kann mir bitte jemand helfen was ich sonst noch einstellen könnte!?
Bitte-Danke

Please Log in or Create an account to join the conversation.

  • Posts: 72051
  • Thank you received: 10915
  • MODERATOR
3 weeks 4 days ago #328931

Hi,

I'm sorry but we don't speak German.
I used Google Translate to read your message, but it's far from perfect.
I understand that you have a problem with the registration on your shop, is that correct ?
Could you provide a URL and instructions to reproduce the problem so that we can check the situation ?

Please Log in or Create an account to join the conversation.

  • Posts: 2039
  • Thank you received: 687
  • Hikashop Business
3 weeks 4 days ago #328937

Hi,

@nicolas:
Nope, this is about users being unable to log in. The warning is the English "You can't access the private section of this site." = language constant JERROR_LOGIN_DENIED.

Back to German:

@togoMedia:
Das liegt mit Sicherheit nicht an HikaShop, HikaMarket & Co, sondern ist eine Joomla-Meldung und kann verschiedene Ursachen haben, z.B. Update von einem (viel) älteren Joomla, Fehler in der Datenbank (was oder wer auch immer sie verursacht hat... aber eben nicht HikaShop oder so), meistens aber eine Fehlkonfiguration von Zugriffsrechten, Usergruppen oder ähnlichem was damit im Zusammenhang steht. Da muss man also schon mal ein bisschen genauer mit Expertenblick schauen, weil sich das hier auf die Schnelle nicht erklären lässt, sorry.

Aber in jedem Fall mal zurückdenken was verändert wurde kurz bevor das Problem auftrat und natürlich ggfs. solche Änderungen rückgängig machen.
Notfalls, falls Expertenwissen nicht vorhanden oder von aussen nicht erwünscht: ein Backup einspielen von Zeiten als es noch lief, und dann Vorsicht mit erneuten Änderungen.

Please Log in or Create an account to join the conversation.

  • Posts: 2039
  • Thank you received: 687
  • Hikashop Business
3 weeks 4 days ago #328938

Hmmm... gerade nochmal nachgedacht... es kann auch sein, dass einfach nur die falsche Zugriffsebene für diverse Joomla-Menüs gesetzt ist. Also am besten mal checken -- zumindest die Joomla-Menü-Einträge, die betroffen sind!

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
  • Hikaauction Standard Hikamarket Multivendor Hikaserial Subscription Hikashop Business Hikashop Style
3 weeks 4 days ago #328943

Thank you very much for the prompt response!
Yes that's right, and I'll send you these instructions a little later. But first I would like to try to get it done in German with lousyfool.

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
  • Hikaauction Standard Hikamarket Multivendor Hikaserial Subscription Hikashop Business Hikashop Style
3 weeks 4 days ago #328945

Hallo @lousyfool
Herzlichen Dank für die Nachricht. MERCI

Ja, es liegt definitiv an mir und nicht am Shop. Ich habe vermutlich zu viel herumgebastelt und probiert. *gg
Das Problem wird vermutlich mein Anlegen von neuen Benutzergruppen sein!?
Ich möchte das sich im MARKET (multivendor) bei „Vendor Registration“ alle automatisch in einer eigenen Benutzergruppe zu finden sind. Da ich diese Benutzergruppe bereits im Backend via ACL-Zugriffsrechte eingestellt hätte.
Und ja, hier fehlt mir noch momentan ein enormes Grundwissen bzgl. dieser ganzen Gruppeneinstellungen zw. Joomla und HikaShop/Market, sowie ich nicht weiß mit „was“ beginne ich und „wie“ ich am besten Schritt für Schritt weiter vorgehe.... usw.

Hier z.B. eine Meldung die ausgegeben wird wenn ich mich im Shop mit einem Test-User anmelden möchte.
„Warnung: Es konnte keine Verbindung zum Authentifizierungsdienst hergestellt werden.“

Ich habe mir auch das „Authentifizierung – LDAP / Plugin“ angesehen. Aber das ist für mich noch alles ein spanisches Dorf.
Hier auch die Einstellungen die in diesem Plugin stehen:

LDAP-Host Feld leer
LDAP-Port 389
LDAP V3: Auf Nein
TLS aushandeln: Auf Nein
Zertifikat ignorieren: Auf Nein
Weiterleitungen folgen: Auf Nein
Autorisierungsmethode: Direkt als Benutzer verbinden
Basis-DN: Feld leer
Suchstring: Feld leer
Benutzer DN: Feld leer
Benutzername: admin
Passwort: ****** (sind 6 Zeichen... aber habe keine Ahnung von wo das herkommt!?)
Attribut: Voller Name: fullName
Map: E-Mail: mail
Attribut: Benutzer-ID: uid
Debug: Nein

...sollte ich das darin richtig verstehen, das sich dann „NUR“ dieser „admin“ anmelden kann?

Ich wäre dir von Herzen dankbar, wenn du mir da bei diesem Anmeldungsproblem und der generellen Benutzergruppen anlegen und freigeben weiterhelfen könntest.

BESTEN DANK

Please Log in or Create an account to join the conversation.

  • Posts: 2039
  • Thank you received: 687
  • Hikashop Business
3 weeks 4 days ago #328946

Hi,

ich hab dir hier gerade eine PM geschickt. Lass uns am besten kurz sprechen, weil ich dann besser verstehe was genau du vorhast und ich dir dann effektiver erklären kann was zu tun ist. Das geht besser und schneller als hier einen Roman zu schreiben, der auch nicht so richtig in dieses Forum passen würde,

Please Log in or Create an account to join the conversation.

  • Posts: 2039
  • Thank you received: 687
  • Hikashop Business
3 weeks 4 days ago #328953

@nicolas:
Just FYI, it's been caused by a misunderstanding/misconfiguration of Joomla usergroups and ACL, indeed. Now resolved.

@togoMedia:
Schön, gesprochen zu haben und dass nun alles gut ist.
Nur zur Info: du siehst, es gibt auch das deutschsprachige Forum hier (wohin die Moderatoren diesen Thread mittlerweile verschoben haben): www.hikashop.com/forum/7-german.html
Ansonsten besser auf englisch posten.
Danke!

Please Log in or Create an account to join the conversation.

Time to create page: 0.074 seconds
Powered by Kunena Forum