Can't change partner currency

  • Posts: 250
  • Thank you received: 7
3 years 10 months ago #208624

-- HikaShop version -- : 2.5.0
-- Joomla version -- : 3.4.3

My shop main currency is set to GBP

On the partner / affiliate pages the currency defaults to euro, and if you change it to GBP it goes back to euros

Ian

Please Log in or Create an account to join the conversation.

  • Posts: 65661
  • Thank you received: 9582
  • MODERATOR
3 years 10 months ago #208650

Hi,

I'm not sure about which page you're talking about. Could you provide a screenshot so that we can better understand ? (don't hesitate to blur sensitive information).

Please Log in or Create an account to join the conversation.

  • Posts: 250
  • Thank you received: 7
3 years 10 months ago #208674

Hi Nicolas,

If you go into your user account and the affiliate section through the front end, as in the screenshot below the currency defaults to euro even though my shop's main currency is GBP. If I change it to GBP and click apply it comes back to euro.



Thanks,

Ian

Attachments:
Last edit: 3 years 10 months ago by iedwards. Reason: insert image

Please Log in or Create an account to join the conversation.

  • Posts: 65661
  • Thank you received: 9582
  • MODERATOR
3 years 10 months ago #208845

Hi,

I tried on my end with the latest version and the changing of the currency is working just fine for me.
Could you provide a link to the affiliate program page, a test user account, a backend access and a FTP access so that we can analyze the issue ?
Please use our contact form along with a link to this thread in order to send the information:
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 250
  • Thank you received: 7
3 years 10 months ago #208982

Hi Nicolas,

I've tried it on a fresh install and as you say it works so something on my site must have broken it. I'll keep looking but may give you a shout if I get stuck.

Many thanks,

Ian

Please Log in or Create an account to join the conversation.

  • Posts: 250
  • Thank you received: 7
3 years 10 months ago #208986

Ok I've found the problem. Despite GBP being the default currency for the shop, and despite having had orders go through and paid in GBP, and GBP being visible in the affiliate currency selector, GBP wasn't actually published in the list of currencies. I have now published it and the affiliate currency selector works fine.

Ian

Please Log in or Create an account to join the conversation.

  • Posts: 65661
  • Thank you received: 9582
  • MODERATOR
3 years 10 months ago #208993

Hi,

I'm glad you found the issue.
We'll do something to force the publishing of the main currency when the configuration is saved.
That will avoid the problem in the future for others.

The following user(s) said Thank You: iedwards

Please Log in or Create an account to join the conversation.

  • Posts: 308
  • Thank you received: 6
  • Hikaserial Standard Hikaserial Subscription Hikashop Business
1 year 4 days ago #292850

Nicolas,

I only have one currency published and that is USD. I have the affiliate partner set to USD. However, the Partner Currency is showing EUR and I can't find how to get that changed to the default USD.

Last edit: 1 year 3 days ago by LukeDouglas.

Please Log in or Create an account to join the conversation.

  • Posts: 65661
  • Thank you received: 9582
  • MODERATOR
1 year 4 days ago #292874

Hi,

If you have the "Allow partners to select their currency" setting deactivated in the HikaShop configuration, then you can't change the currency for each user. Instead, it automatically uses the currency that you've selected in the "Partner's currency" setting of the HikaShop configuration.
Note that if you've disabled the EUR currency and enabled the USD currency in the System>currencies menu, you'll only see the "USD" choice in the dropdown for the "Partner's currency" setting. However, if you don't save the configuration at least once, it is still the "EUR" choice which is recorded in the database for that setting.
So make sure that you save the HikaShop configuration after selecting the currency you want for your partners.

Please Log in or Create an account to join the conversation.

  • Posts: 308
  • Thank you received: 6
  • Hikaserial Standard Hikaserial Subscription Hikashop Business
1 year 3 days ago #292902

Nicolas,

Thanks. I've got it fixed. :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.086 seconds
Powered by Kunena Forum