Issues with Affiliates

  • Posts: 252
  • Thank you received: 6
  • Hikaserial Standard Hikashop Business
1 week 1 day ago #292854

-- HikaShop version -- : 3.4.0
-- Joomla version -- : 3.8.7
-- PHP version -- : 7.2.5
-- Browser(s) name and version -- : Chrome/Firefox/Edge all updated

I'm having a couple of issues getting the affiliate system working. I've setup the banner which works fine. I've activated two users as affiliates. I've setup the affiliate banner on my business website (which I've tested with two different ID #'s - https://webbering.com/extensions/testing-vimeo-player

On the Admin Affiliates / Clicks view, it only displays the referring URL from the website DivorceToolBox.com which the click appeared when I clicked the link on the Affiliate front-end display (didn't really know that worked LOL). However, none of the referring URL's from my website url page ( webbering.com/extensions/testing-vimeo-player ) are there. Naturally, this is the same on the affiliate front end display.



There are NO records on the Affiliate Sales page.
On the affiliate front end display, no unpaid figures are shown.



So the affiliate banner from my website is being picked up but the referring URL is not being saved and the affiliate user is not updated for the

Here is the affiliates configuration settings:



At this point, I'm not sure what I have NOT done that is causing the issue but it looks like it should work? Any ideas?

Please Log in or Create an account to join the conversation.

  • Posts: 62190
  • Thank you received: 8870
  • MODERATOR
1 week 14 hours ago #292872

Hi,

Note that all your tests are done with the same IP address in the same day.
However, you have the "Minimum delay before a new click from the same IP address will be valid" setting set to 1 day.
So basically, most of your tests have just been discarded because of that.
Also, you need to check your browser's cookies.
When someone arrives on your website with the affliate link, HikaShop will store a cookie on his browser for the website with the name "hikashop_affiliate" so please check that you have that cookie.
kb.iu.edu/d/ajfi
At the end of the checkout, when you click on "finish", HikaShop will use that cookie to add the partner to the order.
So please check the orders that you've made in the backend. If you edit them, you should see a partner area with information on the affiliate data, the amount, etc.
If you do, it means that the affiliate sale has been recorded.
However, the affiliate sale will only appear on the partner page once the order has been confirmed (after the payment). Note however that this also depends on how you configured your order statuses in the menu System>Order statuses, and especially the column "affiliate" there. So you need to check all that.

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum