Custom address field not displaied corrclty in checkout

  • Posts: 191
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
3 months 2 weeks ago #301135

-- HikaShop version -- : 4.0.1
-- Joomla version -- : 3.9.1

Hello,
I have a custom address field that is set to be displaied only for country "Italy"
(settings: nimb.ws/2MprGB )
The problem is because "Italy" is also set as default choice in the country list,
my custom field is only displaied if I deselect the country and select it again.

See: nimb.ws/JR1KeQ

You may also test here: accademiainfinita.it/shop
just put some products in the cart and proceed to the ckeckout > new user registration page

Is there a workaround for this without having to switch off the "default country" option?
I would prefer to maintain it as my customer are mainly from Italy.

Thank you

Last edit: 3 months 2 weeks ago by oloccina.

Please Log in or Create an account to join the conversation.

  • Posts: 65130
  • Thank you received: 9460
  • MODERATOR
3 months 2 weeks ago #301199

Hi,

I wasn't able to reproduce the problem on our end. However, looking at the issue on your website, I think I know where the problem comes from.
I've added a patch on our end which should help.
Please download again the install package on our website and install it on yours to get the patch. Let us know how it goes.

Please Log in or Create an account to join the conversation.

  • Posts: 191
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
3 months 2 weeks ago #301224

Hello, it didn't solve the issue

Please Log in or Create an account to join the conversation.

  • Posts: 65130
  • Thank you received: 9460
  • MODERATOR
3 months 2 weeks ago #301229

Hi,

Then, could you provide a backend and a FTP access via our contact form along with a link to this thread so that we can look at it directly on your website since we can't reproduce the issue ?
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 191
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
3 months 2 weeks ago #301268

I was able to solve this thank you

Please Log in or Create an account to join the conversation.

  • Posts: 65130
  • Thank you received: 9460
  • MODERATOR
3 months 2 weeks ago #301270

What was the problem ?

Please Log in or Create an account to join the conversation.

  • Posts: 191
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
3 months 2 weeks ago #301323

I guess it was Jotcache, I disabled it for that page. Now your patch works

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.065 seconds
Powered by Kunena Forum