Always the same variant in basket no matter what characteristic is selected

  • Posts: 15
  • Thank you received: 0
  • Hikashop Business
3 months 2 days ago #305016

Hi there,

In my webshop with courses as products I defined a characteristic with the options "dag" and "avond" ( day and evening).
After adding two variants in the product, the selection of "dag" or "avond" is possible in the front-end as expected, but when I go to the shopping-basket, always the same variant is selected: "avond".

Thanks for your help,
Peter

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
3 months 2 days ago #305017

Hi,

This probably means that you have some view customization on your website which breaks the HTML of the page.
Switch temporarily to the default template of Joomla and try again. It should work properly which would confirm that.
In that case, you would have to check with the person who made the customization of the product page on your end, or your template provider support (meaning that the customization was included in the template).
If you still have the issue even with the protostar template, then please provide a link to the product page with the issue so that we can analyze the situation.

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 0
  • Hikashop Business
2 months 3 weeks ago #305266

Hi,

Thanks for the reply. I did like you suggested, but there are no view customizations and the problem also occurs when I use the Prostar template.
The problem occurs to all products, like go2lean.nl/opleidingen/product/33-hbo-adviesvaardigheden

I created a superuser account for you on www.go2lean.nl so that you hopefully find what the problem is.


There are no javascript-errors. At this moment I do not have any payment-methods installed. Can that be the problem?

Thanks,
peter

Last edit: 2 months 3 weeks ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
2 months 3 weeks ago #305267

Hi,

I'm not able to access your website with the access you provided. I get that error when I try:
monosnap.com/file/DDkKhuBfS8SvkdOAlx8rm3ilfGcp6E
Could you please double check it ?

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 0
  • Hikashop Business
2 months 3 weeks ago #305384

I checked it with cut-and-past from the text below. Can not find the previous login I send you, so it might have been a typo of me.
Please let me know if you still have problems loging in.

This message contains confidential information

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
2 months 3 weeks ago #305387

Hi,

You're right it doesn't come from a view override, which is actually the cause is such case in 99% of the time.
However, the issue is still the same kind. As you can see, the variant data is inside of the form of the product page while it should be outside:
monosnap.com/file/fOJbWjY7VKgnYd78TARxVDQH3BtowU
So it means that there is something which has invalid HTML tags which breaks the HTML on the page.
Looking at the way you build your product page, I can see that you have a lot of custom stuff actually added through custom fields of the table "product". If I disable them via the menu Display>Custom fields, then the HTML on the page is correct and the add to cart button works properly:
monosnap.com/file/AfH6C9AqtlUcFD0hZWKEDJs2FOSkMt
So I looks like the issue comes from the HTML in these custom product fields or the HTML generated by the tags used in these custom fields.

The following user(s) said Thank You: sandvalley2019

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 0
  • Hikashop Business
2 months 2 weeks ago #305527

Hi Nicolas,

Thanks to your reply I could track down the problem. In one of the custom fields there is a form, and nested forms are not allowed.
I will search for a solution for this (maybe a modal-box).

Regards,
Peter

Please Log in or Create an account to join the conversation.

Time to create page: 0.053 seconds
Powered by Kunena Forum