Cannot click Edit or New button for Billing Address

  • Posts: 15
  • Thank you received: 0
2 months 3 days ago #309744

-- HikaShop version -- : 4.0.0
-- Joomla version -- : 3.8.13
-- PHP version -- : 7.1
-- Browser(s) name and version -- : Google Chrome Version 76.0.3809.100 (64 bit)

When we checkout sometimes, the edit link icon or New button below the "billing address" cannot work at all, even after entering the guest checkout information.

Could it be due to the fact that we recently changed order checkout flow, where the coupon code is placed above payment option (and below the address field section)?

Your assistance or resolution suggestion is greatly appreciated.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12168
  • Thank you received: 1677
  • MODERATOR
2 months 2 days ago #309768

Hello,

You actually 2 javascript errors on your checkout page, one is caused by "stickyheader" and the other is cause by the optimisation features of JCH_optimize.

You should probably display JCH, clear your cache and test it again, and if it's coming from it, correctly adapt your optimisation options.

We wish you a nice day !
Kind regards,
Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 0
2 months 1 day ago #309843

Thank you Mohammed.

I have cleared cache in JCH optimise as well as excluded Hikashop.js from optimization list (selected intermediate optimization in profile) but that did not solve the bug.

Any ideas?

Your input is greatly appreciated

Please Log in or Create an account to join the conversation.

  • Posts: 12168
  • Thank you received: 1677
  • MODERATOR
2 months 17 hours ago #309845

Hello,

Can you disable JCH optimize, clear your cache and test it again ? I know that sometime JCH optimize, prevent some script from correctly executing.

Kin regards,
Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 0
1 month 4 weeks ago #309952

Hi Mohamed,

I tried disabling JCH optimise and clear cache, nothing worked.

Any suggestions?

For now, I hide the other address and only have one address instead.

Many thanks

Please Log in or Create an account to join the conversation.

  • Posts: 67110
  • Thank you received: 9946
  • MODERATOR
1 month 3 weeks ago #309982

Hi,

First, I see that you're using the old checkout system of HikaShop. So I would recommend to switch to the new one (since the 3.0.0) by turning off the "checkout legacy" setting in the HikaShop configuration. That will probably help.
If you still have issues with the address edition / creation, then please deactivate temporarily JCH so that we can look at the situation with it disabled as we can't properly look at the javascript on the pages when it is activated. Then, would should be able to help more.

Please Log in or Create an account to join the conversation.

  • Posts: 15
  • Thank you received: 0
1 month 3 weeks ago #310102

Hi Nicolas.

Thank you for your support and message.

I did a test in order after turning off checkout legacy option,

However when I clicked "Next" button after entering address and adding product, the page suddenly refresh to the page showing no checkout elements (address, button, payment etc not showing ). But when I click refresh page again, I can see the checkout.

Any assistance Is greatly appreciated.

Many thanks

Please Log in or Create an account to join the conversation.

  • Posts: 67110
  • Thank you received: 9946
  • MODERATOR
1 month 3 weeks ago #310119

Hi,

I would recommend to turn off the "show submit button" setting of the login view in your checkout workflow after you've deactivated the "checkout legacy" setting.
That way, that will remove the "next" button of the login area so you'll have only the final button at the end. That should prevent the problem.
Otherwise, we would need to be able to look at the problem to analyse the situation and provide a solution.

Please Log in or Create an account to join the conversation.

Time to create page: 0.066 seconds
Powered by Kunena Forum