Change Guest Information not responding

  • Posts: 70
  • Thank you received: 2
  • Hikashop Business
2 weeks 4 days ago #322241

-- url of the page with the problem -- : testing.midwestmeats.com.au
-- HikaShop version -- : 4.3.0
-- Joomla version -- : 3.9.20
-- PHP version -- : 7.3.16
-- Browser(s) name and version -- : Firefox, Chrome

I was running some tests on the latest Joomla version before upgrading my live site.

Just noticed that the function "Change Guest Information" that I wanted to use to change the email address is not working.

When I select it, it takes me back to the Registration page and does not allow me to change anything.

Have I configured something wrong or am I using the feature wrong?

Thanks for your help.

Please Log in or Create an account to join the conversation.

  • Posts: 2647
  • Thank you received: 348
  • MODERATOR
2 weeks 3 days ago #322243

Hello,

We had just process some tests on your website and so far didn't see anything weird in your Guest Checkout.
So, in order to better understand what's going on, can you be more specific by providing these elements like :
- A step by step process in order to be sure to reproduce your issue
- Your Checkout configuration screenshot, and more especially your Login & Registration part
- Any elements that can help us to better understand the issue, like what did you expect and the result, screenshot with annotation, etc etc

Awaiting news from you to be able to help you.
Regards

Last edit: 2 weeks 4 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 70
  • Thank you received: 2
  • Hikashop Business
2 weeks 3 days ago #322284

Thanks Philip

I have attached a document showing the steps to reproduce and checkout configuration.

I can provide you with full access if you need to test on my site.

Thanks and regards
Brett

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12481
  • Thank you received: 1716
  • MODERATOR
2 weeks 2 days ago #322307

Hello Brett,

I just tested it on my end and it worked fine, can you test it with one of Joomla's default template as the issue can be coming from a view's override ? Thank you.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 70
  • Thank you received: 2
  • Hikashop Business
2 weeks 2 days ago #322328

Thanks Mohammed

I reverted to the Protostar template and I can reproduce the issue there also.

I also tried it on your demo system and I can reproduce the issue there.

I have attached steps to reproduce.

Kind regards
Brett

This browser does not support PDFs. Please download the PDF to view it: Download PDF


This browser does not support PDFs. Please download the PDF to view it: Download PDF

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
2 weeks 6 hours ago #322360

Hi,

I found the issue.
The login/registration/guest switcher on the login view of the checkout wouldn't work properly in some cases after clicking on the "change guest information" button with the "user bootstrap v2 design" setting activated because of some javascript initialization not done.
I've added a patch for that on our end and it now works fine for me.
Please download again the HikaShop install package on our website and install it on yours and it will add the patch.

Please Log in or Create an account to join the conversation.

  • Posts: 70
  • Thank you received: 2
  • Hikashop Business
5 days 14 hours ago #322689

Thanks very much Nicolas

I have downloaded the latest release and tested and the issue is now fixed.

Thanks for your wonderful support!

Kind regards
Brett

Please Log in or Create an account to join the conversation.

Time to create page: 0.068 seconds
Powered by Kunena Forum