Using starter version to set up cart for testing

  • Posts: 50
  • Thank you received: 1
3 months 1 day ago #329296

-- HikaShop version -- : 4.4.0
-- Joomla version -- : 3.9.22
-- PHP version -- : 7.3.23
-- Browser(s) name and version -- : Chrome Version 88.0.4324.146
-- Error-message(debug-mod must be tuned on) -- : Australia Post plugin says no postcode set and payment method missing

Being using starter version to setup sample joomla/Hikashop for wife's new suite.

Finally got cart visible with guest user.

Trying to use checkout.
Can fill out address/billing fields.
Cart shows items within.
When hit finish button I get error messages



when I go to "Display->Custom fields" it is not there. Is that due to being teh Starter version.
Will Starter version allow a user to check out fully?
Can I set the postcode without using the Aust. post plugin? I do not have an API.
Edit:
Cleared out cart i.e. removed all items.
Started cart again.
When pressed finish button got new error message


What does the new message mean?

Attachments:
Last edit: 3 months 1 day ago by timknell. Reason: New error message

Please Log in or Create an account to join the conversation.

  • Posts: 72738
  • Thank you received: 11091
  • MODERATOR
3 months 1 day ago #329299

Hi,

There is no restriction on the checkout with the Starter edition.
The post code custom field is automatically installed and you should find it in Display>Custom fields. Please double check.
If you don't find it, please provide a screenshot of what you see there.
Also, make sure that you enter your post code as a merchant and your Australia Post API key in the settings of the shipping method in System>Shipping methods or you won't be able to use it. If you don't have an API key, you'll have to check with Australia Post on how to get one if you want to use that plugin. Alternatively, you can disable that shipping method and instead create manual shipping methods and set shipping fees the way you want.

The "no payment method found" error indicates that you need to configure a payment method in the menu System>Payment method. If you did and it's not appearing there, it's probably that you didn't configure it properly. I would need a screenshot of its settings to tell you what's wrong.

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 1
2 months 4 weeks ago #329503

Nicholas
Thank you for your reply.
The path I have now taken after some searching is
Extensions -> HikaShop - > Upper Horizontal menu Display tab -> Custom fields -> address_post_code
Attached is the screenshot showing the address_post code and then it opened. No sure what to enter and where.

(It is confusing that their are actually 2 (two) tabs called Display and both on horizontal menus.)

I found an API key from Aust. post and entered it too. Hopefully in the right place.
See attachment.

Tim

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 72738
  • Thank you received: 11091
  • MODERATOR
2 months 4 weeks ago #329506

Hi,

The Australia Post shipping plugin requires the address of the customer.
And to be able to enter the address as a customer, you need to allow for the user registration in the options page of the Joomla user manager:
docs.joomla.org/Allowing_user_registration

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 1
1 month 3 weeks ago #330783

Nicholas
Still trying to get my first order done via the cart.
I set up the user registration as noted in the previous reply.
The user can add to the cart, go to the checkout and proceed to register. I am not creating a user account on the front shopping

page.

Now it is telling me that the e-mail confirmation is not the same as the e-mail entered. See attachment.
I have been very careful to enter the passwords identically but using 2 different e-mail addresses gives the same result.
I tried not entered a user name and entering a user name.
I have not altered the e-mail domain options.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 72738
  • Thank you received: 11091
  • MODERATOR
1 month 3 weeks ago #330801

Hi,

I just checked on your checkout and I had no problem registering.
Please make sure that you fill in all the fields that are required and that the email confirmation field has the same text as the email field and that the password confirmation field has the same text as the password field and it will work.

The following user(s) said Thank You: timknell

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 1
1 month 2 weeks ago #331136

Nicholas
I tried again and it worked this time.
I have finally sent my first test orders with Hika shop within Australia.

The following user(s) said Thank You: Philip

Please Log in or Create an account to join the conversation.

  • Posts: 3174
  • Thank you received: 418
  • MODERATOR
1 month 2 weeks ago #331143

Hello,

Thanks for your return, always happy to read good news like this.
We remain at your disposal if you need advice or help.

Regards

Please Log in or Create an account to join the conversation.

Time to create page: 0.084 seconds
Powered by Kunena Forum