The timezone could not be found in the database

  • Posts: 1
  • Thank you received: 0
1 year 7 months ago #287477

-- HikaShop version -- : 3.3.0
-- Joomla version -- : 3.8.5
-- PHP version -- : 7.0
-- Browser(s) name and version -- : Chrome 63.0.3239.132
-- Error-message(debug-mod must be tuned on) -- : DateTime::__construct(): Failed to parse time string (null) at position 0 (n): The timezone could not be found in the database

Good day,

After installing the Hikashop component I want to create my first product. After entering te prize and saving the record I get this error message:
'DateTime::__construct(): Failed to parse time string (null) at position 0 (n): The timezone could not be found in the database'

What do I do wrong?

Thanks!

Attachments:
Last edit: 1 year 7 months ago by Jerome.

Please Log in or Create an account to join the conversation.

  • Posts: 66836
  • Thank you received: 9872
  • MODERATOR
1 year 7 months ago #287497

Hi,

Thank you for your feedback. We've added a patch for that. Please download again the install package on our website and install it on yours and that will fix the problem.

The following user(s) said Thank You: jovi

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 1
1 year 7 months ago #287627

-- HikaShop version -- : 3.3.0
-- Joomla version -- : 3.8.5
-- PHP version -- : 7.0
DateTime::__construct(): Failed to parse time string (null) at position 0 (n): The timezone could not be found in the database

Hi,

I have the same error message but with a hikashop already containing products.

Can I use the same method without losing the already encoded products?

"Please download again the install package on our website and install it on yours and that will fix the problem."
Thanks !

The following user(s) said Thank You: jovi

Please Log in or Create an account to join the conversation.

  • Posts: 66836
  • Thank you received: 9872
  • MODERATOR
1 year 7 months ago #287630

Hi,

Yes, you won't loose your products or settings when you do that. It will just add the patch.

The following user(s) said Thank You: MRPB

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 1
1 year 7 months ago #287689

Thank you. All went well. No data lost

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
5 months 2 weeks ago #305370

Hi, I'm facing the same problem. Where can I find the patch to correct the issue, please?
Thank you, Sue.

Please Log in or Create an account to join the conversation.

  • Posts: 2214
  • Thank you received: 297
  • MODERATOR
5 months 6 days ago #305724

Hello,

You will have to details more the context, can you provide :
- Your Joomla version
- Your HikaShop version
- Precise if you have the same error message from new HikaShop install or not
- Does the error message appear in the same condition and context.

Awaiting details to move forward on your subject
Regards

[MODERATOR :]We are really sorry for the answer delay, we have faced an issue with our work tools which lead us to not see your message until now.
This issue only concerns the first message of users, and so we are sorry that our first contact with you didn't go well.
Once again sorry for the inconvenience.
The HikaShop Team

Last edit: 5 months 6 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
5 months 6 days ago #305747

Hi, thanks for replying :)
So, follow my joomla website details configuration:

Joomla version 3.8.6
Hikashop version: HikaShop Starter 3.3.0

The error I'm getting is when I try to change the product value (include restrictions) and save. The message that appears is:

"DateTime::__construct(): Failed to parse time string (null) at position 0 (n): The timezone could not be found in the database "

I think this error starts to appear after I did a backup using Akeeba and restore it in a new instance. So, I didn't install hikashop again, I just created this backup and restored it in a new joomla site.

Is there any patch that I could apply? Or some configuration on the database that needs to be done? because based on the message error, it seems it's related to the timezone, but it seems to be correct, as I use some date functions on my application and it's working fine.

I will really appreciate if you can give some guidance to solve this issue.
Thanks, Sue.

Please Log in or Create an account to join the conversation.

  • Posts: 66836
  • Thank you received: 9872
  • MODERATOR
5 months 5 days ago #305749

Hi,

You should update your HikaShop and that should help.

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
5 months 5 days ago #305769

Right, and how do I do it? Which version should I get ? Could you please send me the link? Thanks.

Please Log in or Create an account to join the conversation.

  • Posts: 66836
  • Thank you received: 9872
  • MODERATOR
5 months 2 days ago #305800

Hi,

Go in the Joomla updater (menu Extensions->Update of your Joomla backend), click on the "find update" button and then select HikaShop and click on the update button and it will do the update.
It's basically the same for most extension installed on a Joomla website unless it doesn't support the Joomla updater for one reason or another (most extensions support it though).

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
5 months 2 days ago #305829

Hi, thanks for your message :)

Yes, I did it and it worked!! Now I can save the products normally, the error doesn't appear anymore...

Just one thing I would like to share.. when I try to install the component for update, the first time I got an error related to the size of the package. Then, I have to change the settings in my php.ini files and increase the upload_max_filesize .

Thanks a lot for the help!
Sue.

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum