Facebook debug - The 'og:image' property should be explicitly provided

  • Posts: 99
  • Thank you received: 0
  • Hikamarket Multivendor Hikashop Business
9 months 5 days ago #302351

-- HikaShop version -- : 4.0.1
-- HikaMarket version -- : 3.0.0
-- Joomla version -- : 3.9.1
-- PHP version -- : 7.0.2
-- Browser(s) name and version -- : CHROME
-- Error-message(debug-mod must be tuned on) -- : The 'og:image' property should be explicitly provided

Hello,

When I test a product page (see URL of the page) with developers.facebook.com/tools/debug/

I have :
Warnings - That Should Be Fixed
Inferred Property
The 'og:image' property should be explicitly provided, even if a value can be inferred from other tags.

And overall when I test the same page with socialdebug.com
I have terrible results, F...

Do you have documentation/optimization about social sharing? Could you please help?

Regards,

Last edit: 9 months 5 days ago by ChristopheMG. Reason: social debug link

Please Log in or Create an account to join the conversation.

  • Posts: 67119
  • Thank you received: 9946
  • MODERATOR
9 months 5 days ago #302352

Hi,

Well, it's normal that you have these issues since you didn't activate the HikaShop social networks plugin via the Joomla plugins manager and thus you don't have any open graph meta data added to the page as these meta data are added by that plugin.

It seems that you're using something else to have a facebook and a twitter button on that product page, but what you're using doesn't add the open graph meta data.

The following user(s) said Thank You: ChristopheMG

Please Log in or Create an account to join the conversation.

Time to create page: 0.052 seconds
Powered by Kunena Forum