Safari can't open page on product save

  • Posts: 11
  • Thank you received: 0
2 years 2 months ago #316220

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.15
-- PHP version -- : 7.3.6

Hey,

Every time we want to save a product the page goes black with the notice "Safari can't open page". (...)Server is to busy.(...)

I have contacted the webhost and they advised me to up some php flags.

Can you advise me on the right settings for Hikashop?

php_value upload_max_filesize
php_value post_max_size
php_value max_execution_time
php_value max_input_time
And may these as well
php_value memory_limit
php_value max_input_vars

Thank you very much.
Wim

Please Log in or Create an account to join the conversation.

  • Posts: 75529
  • Thank you received: 11766
  • MODERATOR
2 years 2 months ago #316231

Hi,

The default settings of PHP should be fine.
Now, it depends on the situation. If you have a lot of extensions on your website, some of these values might need to be higher. Or if you have a lot data to save.
The thing is that there is not one answer. It depends on the situation.
Usually, a memory limit set at 128M, a max_input_vars set at 2000, a max execution time set at 30 seconds, a post_max_size set to 32M and a upload_max_filesize set to 32M should be enough.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
2 years 2 months ago #316270

Hey Nicolas,

Those numbers are the same.

There are not much extensions installed.
Akeeba Backup, JCE, Hikashop, cciDEAL (payments), and Phoca Open Graph content/system plg.

Not much data either, it's an empty shop.

Regards,
Wim

Last edit: 2 years 2 months ago by iwim.

Please Log in or Create an account to join the conversation.

  • Posts: 75529
  • Thank you received: 11766
  • MODERATOR
2 years 2 months ago #316282

Hi,

Well, that's a lot of websites, but if it came from that, then all the pages would generate that error not just the save of the product. So I'm also thinking it comes from the PHP settings.
I would say that the main culprit is probably max_input_vars.
Note that if you have suhosin installed on the server, it has its own flags for the number of input variables:
medium.com/@themehigh/what-is-max-input-...ange-it-d95d576cb0c6

Please Log in or Create an account to join the conversation.

Time to create page: 0.062 seconds
Powered by Kunena Forum