Error when creation of category

  • Posts: 26
  • Thank you received: 2
2 years 3 weeks ago #342080

-- HikaShop version -- : 4.6.0
-- Joomla version -- : 4.1.4
-- PHP version -- : 8.0.18
-- Browser(s) name and version -- : Chrome 99.0.4844.51 (Officiële build) (64-bits)
-- Error-message(debug-mod must be tuned on) -- : 0 Attempt to assign property "old" on null
Call stack
# Function Location
1 () JROOT/administrator/components/com_hikashop/classes/category.php:184
2 hikashopCategoryClass->save() JROOT/administrator/components/com_hikashop/classes/category.php:155
3 hikashopCategoryClass->saveForm() JROOT/administrator/components/com_hikashop/helpers/helper.php:2081
4 hikashopController->store() JROOT/administrator/components/com_hikashop/helpers/helper.php:2021
5 hikashopController->apply() JROOT/libraries/src/MVC/Controller/BaseController.php:735
6 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/administrator/components/com_hikashop/helpers/helper.php:2238
7 hikashopController->execute() JROOT/administrator/components/com_hikashop/hikashop.php:73
8 require_once() JROOT/libraries/src/Dispatcher/LegacyComponentDispatcher.php:69
9 Joomla\CMS\Dispatcher\LegacyComponentDispatcher::Joomla\CMS\Dispatcher\{closure}() JROOT/libraries/src/Dispatcher/LegacyComponentDispatcher.php:71
10 Joomla\CMS\Dispatcher\LegacyComponentDispatcher->dispatch() JROOT/libraries/src/Component/ComponentHelper.php:389
11 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/AdministratorApplication.php:143
12 Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT/libraries/src/Application/AdministratorApplication.php:186
13 Joomla\CMS\Application\AdministratorApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:278
14 Joomla\CMS\Application\CMSApplication->execute() JROOT/administrator/includes/app.php:63
15 require_once() JROOT/administrator/index.php:32

I haven't found this problem on the support yet, but might have overlooked it.

When trying to create a new category i get a error message.

0 Attempt to assign property "old" on null


Best regards,

Please Log in or Create an account to join the conversation.

  • Posts: 81875
  • Thank you received: 13145
  • MODERATOR
2 years 3 weeks ago #342083

Hi,

Thank you for your feedback. That comes from a wrong copy/paste among the modifications we made for HikaShop 4.6.0 which results in the fatal error on PHP8.

I've made a patch for it on our end. Download again the install package of the 4.6.0 on our website and install it on yours and it will add the patch for it.

The following user(s) said Thank You: alexnovo

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 2
2 years 3 weeks ago #342087

Yes, this did the trick. Thank you for the quick solution.


Best regards,
The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.060 seconds
Powered by Kunena Forum