Coupons: Auto load in cart if possible not working

  • Posts: 27
  • Thank you received: 2
  • Hikashop Business
2 months 1 day ago #337142

-- HikaShop version -- : 4.4.4
-- Joomla version -- : 3.10.3
-- PHP version -- : 7.4
-- Browser(s) name and version -- : any

Hello

Since update to 4.4.4 the coupons are not applied automatically anymore.

I have set coupons as precentage to be applied to products. And I have set "Auto load in cart if possible" to yes. So far this did work all the time: In cart the coupon got applied automatically.

Now this is not working anymore, no coupon gets applied.
Coupons still are set up same so they should work. I did open and save them again but this did not help.

How can I solve this?

Thanks.

Last edit: 2 months 1 day ago by pat01.

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
2 months 1 day ago #337153

Hi,

Could you provide a screenshot of the settings of a coupon which doesn't work so that we could try to reproduce the issue on our end ?
Also, do you use the extension AWOCoupon ?

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 2
  • Hikashop Business
2 months 1 day ago #337161

Hi Nicolas

I don't use AWOcoupons.

I go Orders > Coupons.

Here are the screenshots:




Thanks.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
2 months 1 day ago #337164

Hi,

Thank you. I was able to reproduce the problem and found the issue in the code. I've added a patch on our end.
Download again the install package of HikaShop on our website and install it on yours and it will fix the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 2
  • Hikashop Business
2 months 14 hours ago #337198

Hi

I installed the package and now the issue is solved.

Thanks a lot for your help.

Last edit: 2 months 14 hours ago by pat01.

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum