Search after a search

  • Posts: 19
  • Thank you received: 0
  • Hikashop Business
5 months 2 weeks ago #315779

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.10
-- PHP version -- : 7.2.27
-- Browser(s) name and version -- : Internet Explorer

Hi there!

Houston, we have a problem in Internet Explorer. If I make a search with Hikashop filter module everything works fine. But if I do another one on the same page (listed products), nothing happens. Only appears in IE.

(in console view, something goes wrong with newURL in hikashop.js)

Can you help me about it?

Thanks in advance!

FRIK

Please Log in or Create an account to join the conversation.

  • Posts: 70141
  • Thank you received: 10500
  • MODERATOR
5 months 2 weeks ago #315782

Hi,

You have the warning "Notice: Undefined offset: 1 in /home/friktest/public_html/elaforg/administrator/components/com_hikashop/helpers/helper.php on line 3023" at the top of your pages because you've activated the error reporting in your Joomla configuration. This warning is also added to the response from the server when you do the search with a HikaShop filter.
This renders the response invalid and you get the error with newURL because it cannot find the data in the response:
monosnap.com/file/qrXbs7b4mUEmHJ3D7XXADNxSq8iZi9

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
  • Hikashop Business
5 months 2 weeks ago #315801

OMG...what a noob was I :)

Thank you Nicolas (again!)

Please Log in or Create an account to join the conversation.

Time to create page: 0.055 seconds
Powered by Kunena Forum