Why different output of column order_full_price?

  • Posts: 512
  • Thank you received: 18
  • Hikashop Multisite
8 months 1 week ago #332372

Hi Support,

When we export order and we open the file in Excel and we look al the column order_full_price we don't see consistent input.



For example:

Line 1: We have to change the . (point) to a , (comma)
Line 2: We have to divide the cell by 100000 (hundred thousand)
Line 3: we have to divide the cell by 10000 (ten thousand)

Why? this way we cannot quickly add up because we have to manually check all orders first.

I hope you have a solution for this.

Kind regards,
Lumiga


Kind regards,
Lumiga
Attachments:
Last edit: 8 months 1 week ago by Lumiga.

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11497
  • MODERATOR
8 months 1 week ago #332386

Hi,

That's because of how your software interpret the number with a dot. Instead of considering it as a decimal separator it considers it as a thousand separator and thus it gets messed up.
Change the "decimal separator" setting of the HikaShop configuration to comma instead of dot and it should help when you export new CSV files and open them with your software.
Alternatively, you can configure your software to use the correct separators when you open the CSV file with it. For example for excel, you need to use the "CSV import" tool ( www.hesa.ac.uk/support/user-guides/import-csv ) instead of just double clicking on the file. If you double click on the file, it just use the default presets of your locale (based on your Excel version, and language, it can vary ).

The following user(s) said Thank You: Lumiga

Please Log in or Create an account to join the conversation.

  • Posts: 512
  • Thank you received: 18
  • Hikashop Multisite
8 months 1 week ago #332405

Thanks! Works perfect now! ;-)


Kind regards,
Lumiga

Please Log in or Create an account to join the conversation.

Time to create page: 0.067 seconds
Powered by Kunena Forum