import problem

  • Posts: 75
  • Thank you received: 9
1 month 2 weeks ago #343852

-- HikaShop version -- : 4.6.1
-- Joomla version -- : 3.9.10
-- PHP version -- : 7.4

Hi.
I have a CSV file of my products information in persian language and UTF-8 format.
when I import the file products are created but all texts are converte to question marks.

how can I fix this ?

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
1 month 2 weeks ago #343863

Hi,

How do you do the import ? Did you select the "UTF8" in the "encoding" dropdown before the import ?

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
1 month 2 weeks ago #343864

yes i do

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
1 month 2 weeks ago #343865

can it be related to mu administratir language ?
because although my website is in persian language, my admin interface is english

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
1 month 2 weeks ago #343866

It shouldn't. Maybe there is a problem with the CSV file ? Could you provide a copy of the file so that we could test on our end ?

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
1 month 2 weeks ago #343870

I dont think so.
Sure the file is attached.

Thank you.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76573
  • Thank you received: 12023
  • MODERATOR
1 month 2 weeks ago #343874

Hi,

When I open your CSV file with LibreOffice with the UTF8 encoding I only see question marks:
i.imgur.com/Dmtiq8n.png

So as far as I can see the problem is with the CSV. You must be using another encoding in your CSV.

The following user(s) said Thank You: khashiz

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
1 month 2 weeks ago #343880

I think its because the data is in persian language

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
1 month 2 weeks ago #343881

I did the import with the RO CSVI component.

thank you very much for great support

The following user(s) said Thank You: Philip

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum