Google products file not created, not showing up in Hikashop Plugin List.

  • Posts: 33
  • Thank you received: 0
  • Hikashop Business
6 years 2 months ago #291997

-- url of the page with the problem -- : harborrvservice.com/
-- HikaShop version -- : 3.4.0

I went to Hikashop, system, plugins clicked NEW and scrolled down to Hikashop Google Products Plugin and clicked.
It opened the settings for the plugin, which I filled out, made sure that is Enabled, clicked Save and Close and I see it in the Joomla plugins list, go back to Hikishop plugins and it's not there.
I enabled the cron task and verified that it is working

Last Cron
Last Run time 	2018-04-29 17:10
Triggered from the IP 	94.xx.x.xxx
Report 	HikaShop Triggered at 2018-04-29 17:10


Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 82065
  • Thank you received: 13193
  • MODERATOR
6 years 2 months ago #292027

Hi,

The listing in System>Plugins is only for the plugins supporting mutiple instances, like the user points plugin.
For the others, you can directly access them in the Joomla plugins manager, like the Google Products plugin. So no problem here, just access it via the Joomla plugins manager.
Note that for the plugin to generate automatically a google products file, you first need to enter a path for the file in the "local xml file path" setting. If left blank, then the plugin cannot generate the file since it doesn't know where you want it to be saved on your server.

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 1
  • Hikashop Business
10 months 1 week ago #355079

Hi,

I have entered the file path as "home/useraccount/public_html/" and no file is being generated at this path. File name is set to - products.xml
What am I missing in the configuration? The document nation misses many of the setup form fields.

Thanks.

Please Log in or Create an account to join the conversation.

  • Posts: 82065
  • Thank you received: 13193
  • MODERATOR
10 months 2 days ago #355165

Hi,

You need to enter the full path of the file, not the patch of the folder where the file is.
So it should be something like /home/useraccount/public_html/products.xml
When you're editing the settings of the plugin, you have a button "help" you can use to display the documentation for each field.
For example, for the local path setting, you'll see:

"Enter here the relative path from the root of your website for the XML file to generate. For example, if you want the URL yourwebsite.com/folder/sitemap.xml for your XML file, enter folder/sitemap.xml in this setting. You can use the tags {language} {date} or {time} so that they get replaced automatically when the file is generated."

Please Log in or Create an account to join the conversation.

  • Posts: 507
  • Thank you received: 21
  • Hikashop Business
9 months 2 days ago #355932

Hi,

I have the same problem. In the past I thought it was related to my serverhost, but on the new server the same problem occurs. No xml file is created. Tried with a path like /jnbgoogle.xml", "producten/jnbgoogle.xml" and "home/my-useraccount/public_html/jnbgoogle.xml" but with the same empty result. See screenshot.

Also the category restriction seems to fail in some cases. There are products in the xml that are not linked to the selected categories See screenshots).

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 82065
  • Thank you received: 13193
  • MODERATOR
9 months 2 days ago #355934

hi,

If the file is not written, it's probably that the folder where you want it to be generated is not writable by PHP. I would recommend to check about this.
Normally, an error message should be included in the report email sent to you by the cron task (if you activate it under the Cron tab of the Hikashop configuration page) which should say something like Could not write Google Merchant file to xxx where xxx will be the full path where the plugin is trying to save the XML file.

Note that the plugin will include all the products of all the categories listed in that option as well as their sub categories.
So if the Opties Kiezen category of your product is, for example, a child category of the categorieen category, it will be included even if you don't specify directly that category in that setting.
Also, it's possible that the category data is not synchronized in the database leading to the plugin thinking that this category is a child of a category it isn't really a child of. To fix that, you can click on the "rebuild" button of the categories listing, which will recalculate the category tree data in the database.

Please Log in or Create an account to join the conversation.

  • Posts: 507
  • Thank you received: 21
  • Hikashop Business
9 months 2 days ago #355957

Hi,

I rebuilded the database and indeed the problem is solved. Thanks.

Please Log in or Create an account to join the conversation.

  • Posts: 507
  • Thank you received: 21
  • Hikashop Business
9 months 2 days ago #355960

The file is stored now, but the upload doesn't arrive at Google merchant. If I use "fetch now" on the merchant center the file does update with the latest xml file.
All the sftp credentials for partnerupload.google.com are set right in the Google Products Plugin. The report is set to "only if Hikashop executes an action" / "Simplified report" (and tried also Detailed report). Filelocation is set, but no report is generated. So I can't see why the upload of the xml fails.

Please Log in or Create an account to join the conversation.

  • Posts: 82065
  • Thank you received: 13193
  • MODERATOR
9 months 1 day ago #355964

Reduce the frequency of the plugin and the frequency of the cron and manually open the cron URL in your browser. You'll directly see the report on your screen.

Also, it could be that the emails are not sent for some reason but still generated. So check the emails in the Customers>Emails history. The cron report emails should also appear there.

Please Log in or Create an account to join the conversation.

  • Posts: 507
  • Thank you received: 21
  • Hikashop Business
9 months 1 day ago #355982

I tried that several times before, but did this one more time. The screenmessage shows "HikaShop Executed at 2023-10-19 10:17" and "The system will not run for ..." See screenshots. The email is sended with the same message, but no report attached. When opening the report with the button a message "Logfile is empty" is displayed.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 82065
  • Thank you received: 13193
  • MODERATOR
9 months 1 day ago #355983

Hi,

The messages "HikaShop Executed at 2023-10-19 10:17" and "The system will not run for ..." means that the cron was already triggered by the cron before you manually did it.
For example if you configure the cron frequency to 10 minutes and your HikaShop cron triggers it at 10:00 am, then if you manually call the URL anywhere from 10:00 to 10:10, you'll get that message.
This frequency check is done to avoid bots potentially overloading your server with cron tasks.
So what you need to do is to change the frequency to 1 second temporarily. That way, when you open the URL, the last time it was triggered will be bigger than 1 second and the cron will run.
Note that as I was saying in my previous message, you also have to change the frequency of the google products plugin itself.

Please Log in or Create an account to join the conversation.

  • Posts: 507
  • Thank you received: 21
  • Hikashop Business
9 months 23 hours ago #355990

For me it's not quite clear how these two commands sync together. I've changed the "Minimum delay between two cron tasks" to 1 second, I suppose that's what you ment (as the minimum frequency can only be set to 15 minutes). The frequency in the plugin was already lowered to 900, but now set to 60 seconds. So when and how is the cronjob triggered by these params?

Now, when hitting the link there's a 404 error page: in the header I can see "Cannot connect to partnerupload.google.com..."
But the credentials are ok, as I can access and upload the xml to Google through sftp with Filezilla without any problem.

Please Log in or Create an account to join the conversation.

  • Posts: 82065
  • Thank you received: 13193
  • MODERATOR
9 months 20 hours ago #355994

Hi,

The fact that you got the 404 error page with the "Cannot connect to partnerupload.google.com..." error message indicates that the plugin was triggered and it regenerated the XML feed file.
And that actually explains why you didn't get the report. PHP stopped the processing of the page when that error happened and thus HikaShop couldn't do anything.
We'll have to change a bit the code of the plugin to better handle connection errors so that we can get a soft fail in order to handle the reporting.

However, this also means that the problem is not in the plugin nor how you set it up.
The problem is that you probably have something on your server not allowing outgoing connections. It could be a firewall, or simply cURL not being available, or openSSL not available or some php.ini restriction, or something like that. I'm afraid you'll have to check with your hosting support.
Note also that SFTP is not available on Joomla 3. I'm not sure which version of Joomla you're using but you need at least version 4 to use the SFTP upload capability of the plugin.

Last edit: 9 months 23 hours ago by nicolas.

Please Log in or Create an account to join the conversation.

Time to create page: 0.112 seconds
Powered by Kunena Forum